Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Controller Config Moving Down options and skipping buttons all by itself



  • Hi all,
    First up
    Raspberry Pi 3B
    SanDisk 64GB SD Card
    Standard 2.5 Amp Official Raspberry Pi PSU
    4 x Logitech F710 Wireless Controllers
    1 x Logitech Wireless Keyboard and Mouse
    Running Retropie 4.4

    After a recent update I have encountered 2 issues:

    1. Pi prompts for a login when starting up before it loads Emulation Station. This I have fixed.
    2. Controller configs screwed up. I have cleared the controller configs and attempted to reconfigure each of the 4 controllers. most buttons configure fine but when I get to right trigger it sometimes accepts it other times says NOT DEFINED and then skips down 2 or 3 by itself. This behaviour but with slightly different buttons occurs on the other controllers as well. I have tried unplugging the wireless receiver for the keyboard and mouse and also tried unplugging all the other controllers and doing them one at a time.

    Any suggestions?

    Thanks,
    Dwarfboysim


  • Global Moderator

    @Dwarfboysim Re-install the xpad driver, reboot and re-try the configuration.
    I think the update overwrote the xpad driver installed by RetroPie and you're using the default xpad driver, which treats triggers as analog axis instead of buttons.



  • Thanks that fixed it :)

    Also now have a fresh install of 4.4 up and running beautifully.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.