Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Scraping help, not reading info from hdd



  • I was going to ask this in my last topic but thought it better to create a separate one for the benefit of future users.

    Ok with help from the awesome @mitu I've now got my splash screens working off my hdd but now I need help with my scraped images lol.

    Before I start I would like to say I know the gamedb isn't working at the moment so with that said here is my problem.

    I have scrapped rom images using Stephen selph's scraper and it worked downloading the images, descriptions and so on however when I load the games lists in retropie there are no images or anything just the base list.

    Ive also used uxml scraper which also downloads all of the relevant information but when I go into the games list there are still no images or anything.

    If I disconnect the hdd and put a game on the sd card instead and scrape that rom it will download the images and such then when I load the games list where that game is it will show me the images and everything like its supposed too.

    So basically I need help figuring out how to make my pi read the game information while my hdd is plugged into the pi.

    The hdd was initially set up by formatting as fat 32 then creating the retropie-mount folder on it then plugging it into the pi for the pi to create the rest of the required folders within the retropie-mount folder.

    Again any help will be mucb appreciated
    Thank you.

    Raspberry pi 3+
    Running retropie
    32gb sd card
    120gb external hdd

    EDIT: I managed to get it working!

    OK so after a little bit of searching I came across an extremely helpful video on YouTube by a youtuber by the name of ETA PRIME

    it looks like even though I had configured selph's scraper correctly I hadn't enabled option 8 "Use rom folder for gamelist & images"
    by enabling this option it saves all boxart, videos and so on in the corresponding rom folders.

    Because option 8 wasn't enabled it seems that when scraping the roms the scraper would download the images and such to the HDD I have connected HDD but when scanning for images/videos in the games list I think emulationstation is looking for the files either on the empty SD card instead of the HDD or on the HDD in via the wrong file path or the images were downloading to the wrong place.

    By enabling option 8 it obviously downloads all of the images and such directly to the rom folders putting them in the correct place to be read when called upon in emulationstation.

    Anyway this is my setup on Steven Self's scraper just in case anyone else was having the same issue these settings will fix everything.
    setup

    I hope this helps others facing this issue, and once again to @mitu for offering their wisdom on the matter.


  • Global Moderator

    How did you scrape your games ? From your PC or from the Pi ?
    After scraping, the scraper program would create a gamelist.xml in the ROMs folder, can you get the contents of such gamelist.xml (that's not working) and paste it on pastebin.com to take a look ?



  • @mitu said in Scraping help, not reading info from hdd:

    gamelist.xml

    Thank you very much for your reply I have managed to fix it now!
    I have edited my original post and added the soloution at the bottom.

    much appreciated once again, and not to worry ive more questions on the way lol.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.