Please do not post a support request without first reading and following the advice in

  • Hi everyone. Definitely searched around a lot and can’t get much consistent info about this issue.

    I have Retroarch 1.7.1, retropie 4.4, on a raspberry pi 3b+ with a generic PlayStation style usb controller hooked up and a Dolphinbar with wiimote in another usb slot.

    My wiimote is paired to the Dolphinbar and not directly to the pi Bluetooth.

    My Dolphinbar is in mode 2 with the wiimote led lights one and four lit up.

    In the retroarch menu user 1 binds are set to have the mouse at index 0 and user 2 binds are set to have the mouse at index 0. In the other part of the retroarch GUI menu I have enabled the mouse type as “pointer.”

    I have no other keyboard or mouse plugged in.

    With this setup, my NES emulator (lr-fceumm) runs great. The cursor appears on screen. The trigger shoots the ducks in duck hunt or the baddies in Hogan’s alley. The plus button on the wiimote also works as the start button. If I want to exit the game I can still press start and select on my usb controller.

    So in some way I know the hardware “works.”

    Now here is where things get wonky.

    I open Jurassic park in either lr-mame2003 or lr-mame2003 plus. Cursor is showing on screen, I can only move it with the left analog joystick on my usb controller NOT the wiimote BUT if I pull the trigger on the wiimote it fires the gun in game. But I can’t get the wiimote to control the gun cursor. Meanwhile I try Lethal Enforcers 2 and I can see two gun cursors. I can move one with my wiimote but pulling the trigger on the wiimote fires the other, non-moving gun cursor. I can’t fire the cursor I can move with my wiimote. I can move the other cursor with my left analog stick. So somewhat the same as Jurassic park in that the combination of moving the left analog stick and pulling the wiimote trigger will fire a gun but different from Jurassic Park in that there is a second gun cursor I can actually move with the wiimote.

    I open Lethal Enforcers on genesis with the lr-genesis-plus-gx emulator. (Tried pico drive first but seems there is no way to get it to recognize a controller as a gun, let me know if I am wrong on that.). This emulator allows you in the retroarch menu in controls to select User 2 as using an “MD Justifier” and player 1 is set to a joypad. This actually seems to replicate how the original game was played as I found a manual online and you plugged a game controller into port 1 and justifier gun into port 2. Making the setting this way and restarting the game through the retroarch menu now allows me to see a red gun cursor that I can move around with my wiimote, the setting to use a “gun” instead of a joypad for player 1 becomes available in-game and I can use the plus button on the wiimote to press start in game. Seems like it will work just like NES. But when the game starts, no button on the wiimote OR controller will actually fire the gun. I tried hitting every button. I can just move the sights around the screen, die, pause or continue.

    In lr-pscx-rearmed I see no option for it to recognize I have a gun plugged in. If I am missing anything or a different emulator works let me know. Would be great to have PSX work since Area 51, time crisis and lethal enforcers are on that system which would be perfect. If I could get only one system to work with dolphin bar other than NES,PSX would be the one I would choose.

    SegaCD, which has Maddog McGee, only seems to work with picodrive not lr-genesis plus so seems like I am stuck there too.

    SNES emulator (whatever the default one is, I think it is SNES2010) has retroarch GUI options for mouse, superscope, etc, as user 1 and user 2 inputs but none seems to put a cursor on screen or recognize my wiimote at all, with the sole exception of Mario Paint which works fine when I say I am using a mouse. So no traction there with the light gun games.

    I saw some posts saying that Retroarch updated the code to allow more universal support for “Lightgun” type devices but from my experience as described above this doesn’t seem to be the case - though seems with most issues on RetroPie it turns out to be user error and code is right. Just not sure what the user error is here.

    I also see posts saying that advancemame 1.4 works great without need for special configs, problem is I don’t have those ROMS and don’t want to have to / don’t have the hard drive space to download 50gb of a full .106 Romset so that I can “hope” like 5 light gun games (Alien 3, terminator 2, Maddog McGee, lethal enforcers 1 and 2) wind up working. Even then it would be better if I could find a PSX solution since that would also allow me to play time crisis which I see is too slow for Mame, plus a lot of the other light gun games.

    Has anyone experienced the same issues and found a “fix” for any of the above? PSX working with dolphin bar? Genesis working with dolphin bar? SegaCD? Lr-mame2003? SNES (other than Mario paint)?

    I saw the wiki page on retroarch that has a paragraph on trackballs, Lightguns, etc. that says to change the retroarch config TEXT file to reflect the mouse as a pointer but given that it seems in multiple emulators my wiimote “motion” is at least recognized, and that I have already changed this setting in the GUI, I am afraid to change this setting in the text file and screw up NES which is fully working unless someone tells me this is the fix to all of the other problems for sure.

    THANK YOU for any help someone can provide. And if your solutions work seems like this thread will be a great all-in-one resource to get dolphin bar working for everyone!

  • Hi there.

    I'm very intrigued that you got anything to work in Genesis Plus. I've been trying to get that to work forever all basically for one game I grew up playing (Rescue Mission on Sega Master System). Was wondering if you could test that game on your end to see if it works on Genesis Plus with your configs? (Also, to confirm, do you have the DolphinBar plugged into the second port on your Pi - top right, instead of the first - top left, and this works on Genesis Plus?)

    Jurassic Park works fine for me on AdvMame 1.4, so try switching your emulator to that (though it is a bit choppy, but still plays).

    As for PSX, there is now light gun support, I've heard, not for rearmed but for beetle, but I haven't tried it yet.

    I have over 50 games that work great for me in AdvMame, including Alien 3, Terminator 2, Lethal Enforcers and I think MadDog McGee. Other favorites are Operation Wolf, Operation Thunderbolt, Rail Chase and Police Trainer. I can get you a full list if you like.

  • @BGallagherLA hi thanks! Yes I have dolphin bar in the second port but Genesis only half works so isn’t really useful. Kind of frustrating actually because it feels like it is JUST there. NES works at least so there is duck hunt. My problem with advancemame is having to do a different romset and right now I can only find it in an 80 part zip that doesn’t have an index for which letter games are in each zip with the light gun games all scattered throughout. Maybe I could download the first part which would likely have aliens and area51 at least and try that. I will double check exactly what I did in genesis for you so maybe you can find out how to complete it ha. I saw that about Beetle PSX working but everything I have read says Beetle doesn’t run on pi. I did see something last night that maybe snes9x works (the one that doesn’t have the years like 2010) so I am going to try that tonight as well and let you know!!

  • Yeah so dolphinbar is in top right usb slot, ran lethal enforcers on genesis plus emulator, retroarch GUI menu set user 2 device type as MD Justifiers, and under retroarch GUI options show light gun crosshair is enabled. I think I am on retroarch 1.7.3 and the emulator says v 1.7.4 02aa222e. At that point I see a Red Cross hair on screen when I move the wiimote. I can use plus on the wiimote to start. Gun option is available under player 1 and I can start the game. However nothing will work to shoot the gun. Oddly if I select the 2 players joypad and gun option I can move the second gun cursor with the directional pad on EITHER the joypad or the wiimote (both love the same cursor), I can move the second cross hairs by moving the wiimote and when I click the trigger on the wiimote it fires the gun but it is the gun crosshair connected to the dpad not the one I can move with the gun. This is frustrating because it seems on some level everything I need is working - the trigger registers to an extent, the plus button registers as start, and the wiimote’s motion is triggered but I just can’t get them to all work in concert!!

  • @BJRetro You don't need the whole romset. You can just get individual games from various places. I can send you what I have if you like.

  • @BGallagherLA hi on the rom you wanted me to test on Genesis I don’t have that one but my guess is it would only half work which means effectively not be usable like the other games I tried. I also realized I am an idiot because I didn’t realize I could use .78 ROMS in advancemame 1.4. I did that now and got it working for a lot of games, with one still frustrating nit for now. I was hoping to do this on my barcade once I figured it out on my console style setup. But the only way I eventually got it working was to fully unplug the regular usb controller (which meant I had to configure the wiimote in emulation station to be able to select a game to play) because otherwise I could move a cursor on screen but there was another cursor that stayed put and my trigger was firing at that cursor not the one I wanted it to. But I don’t want to mess with unplugging my xin mo on the bartop every time I want to play a light gun game. My guess is there is some way to fix advancemame so it ignores the joysticks and controllers but will have to look into it more. But at least I can play NES and arcade shooting games now!!

  • @BGallagherLA hello do you have a list of the lightgun games for advanced name?

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.