Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Preview with sound but no video



  • I recently updated my retro pie. Afterwards all my game previews stopped working. There is no video anymore but there is audio. Any ideas how to fix it?


  • Global Moderator

    @karatsu Try switching to Omxplayer in Emulationstation for the video previews - turn on the hardware accelerated video player.



  • @mitu I turned it on and put my vram at 120. I lose audio and there is still no video



  • OK, so I too tried out video previews as the scraper had this option, and I also get sound but no video. Tried switching back to Carbon and doing the above (Omxplayer, fiddling around with VRAM etc) and the same happens. No sound OR video at all.

    Worth mentioning perhaps is that when I get sound there is a static black image where the video should be.


  • Global Moderator

    @Diosyntaxa Omxplayer has problems with some videos that use a certain video codec. Do the videos work without OMXplayer (i.e. using the VLC based player in Emulationstation) ?



  • @mitu
    Not sure what you mean, but I'm guessing you're asking if it works without HW acceleration (Omxplayer) turned off, and the answer is: I get sound but not video.


  • Global Moderator

    @Diosyntaxa What is your system configuration - https://retropie.org.uk/forum/topic/3/read-this-first. What scraper did you use to get the videos ?



  • @Diosyntaxa In addition to @mitu's request, you could show us the codecs of one of the videos. Maybe they are in some exotic video format.

    To do so, execute the command ffprobe in the command console you land in if you press F4 in Emulation Station, followed by the path and name of the video file, e.g.

    ffprobe /home/pi/RetroPie/roms/arcade/images/somegame.mp4
    

    Use brackets if either the path and/or the filename have spaces or special characters:

    ffprobe "/home/pi/RetroPie/roms/arcade/images/some game with spaces.mp4"
    

    If the command is said to be not known or installed (though it should be on a standard RetroPie), you can install it with this command:

    sudo apt install ffmpeg
    

    You can exit the console with the command exit.



  • it was all ok for me since a long time... but last update killed my video screen to black... sound still there...
    omx does not want the videos : black screen no sound
    it used to work without OMX...
    I compared the videos with an older version of retropie.. they are the same (same size, same name.....) after an update/upgrade it came to black screen with sound... screen saver does the same...

    (I can remotely play the videos via samba with a PC and VLC... so it is a double check those videos are ok)
    mp4 type...)
    any clue ?
    thanx a lot !


  • Global Moderator

    Can you add more info about your system and - maybe - upload one of the videos somewhere so we can take a look at it ?



  • thank you very much indeed for such a quick answer !
    those are the screens with black videos (all videos look black but sound is clearly audible and normal)
    Aerofighter black video with sound
    https://www.casimages.com/i/190717105659278761.jpg
    another game video :
    https://www.casimages.com/i/190717105659538424.jpg

    this is the view of my retropie linux prompt when I hit F4 from within emulation station
    https://www.casimages.com/i/190717105700226746.jpg

    this is the wetransfer link to the rar file containing tested videos from the lan...
    https://we.tl/t-xMMgreDAT2

    Rapberry pi3
    wireless 2.4 ghz generic keyboard
    wireless microsoft 360 gamepad
    Sony tv 40" 1920x1080 hdtv
    hdmi cable
    retropie version:
    https://www.casimages.com/i/190717112436240225.jpg

    do not hesitate to ask if you need more info..

    thanx a lot


  • Global Moderator

    OK, so it seems it's the old problem with video from ProgettoSnaps, recorded from MAME. They're encoded with a rarely used color encoding space that's not supported by the hw Mpeg4 decoder on the Pi (yuv444p), so that's why the video display isn't working.
    There are several scripts to re-encode these videos (https://retropie.org.uk/forum/topic/15764 is one) to make them show correctly in Emulationstation.

    What's new is that the VLC based (internal) video player in Emulationstation doesn't show them either and it used to work. I guess that since the VLC player got patched by RPF to also use HW accelerated video decoding, the same omxplayer behavior happens.

    For now, converting the videos is the only solution. Using `ffmpeg, this can be done quickly with

    ffmpeg -i <input_video> -pix_fmt yuv420p <output_video>
    

    but any of the conversion scripts available in the forums will do.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.