Please do not post a support request without first reading and following the advice in

  • Hi, people. This is my first thread, since every issue I have experimented in the past was solved here.

    Here we go:

    Pi model: Raspberry Pi 3B
    Power supply: generic one, USB, output: 5V DC, 2000mA
    Retropie version used: 4.4.4
    Built from: fresh 4.4 official version from RetroPie website and manually updated
    USB devices: 1TB WD HDD for roms storage
    Controller used: generic USB keyboard and PS2 gamepad with USB adapter
    Error message received: NA
    File: every custom collection .cfg

    I know how to create custom collections and how to manage them, since I have using RetroPie for a while, but it seems there is something wrong with my current configuration, since every time a create a new custom collection, everything starts to fail... And I mean that no roms are loaded (custom collections, favourites, last played and regular roms) and even RB configurations option just give me a black screen.

    I have found that if I unmount the HDD, options work again, so I can delete custom collection .cfg file via file manager and everything works great again. But I have seen something strange (at least to me): if a use View option from file manager, routes seem to be OK, but if I selecte Edit option, I can see another level inside the routes: FAVORITOS (yes, in Spanish; I'm Spaniard, BTW).

    Is this new level the problem? If so, any easy way to edit .cfg files via PC?

    PS: Favourites and last played work flawlessly.

    Thank in advance!

  • Global Moderator

    My guess is that your disc is coming online (mounted) after Emulationstation starts and your ROMs are not available until then, hence Emulationstation cannot find them. Add a delay before Emulationstation starts to give enough time for the disc to come online.

  • @mitu It sounds plausible, thank you so much. But the same HDD worked before.

    Just to try, of course, how could add such delay?

  • Global Moderator

    @ADP80 Edit the script and add sleep 5 on a line before emulationstation - see

  • @mitu said in Custom collections issue:

    @ADP80 Edit the script and add sleep 5 on a line before emulationstation - see

    Thank you, I will let you know as soon as I try it.

  • @ADP80 said in Custom collections issue:

    I just can't save this change. I thought I just needed to control+X, but it does not work here.

  • Global Moderator

    @ADP80 I don't have a PI right now to check, it might be enough just to do your changes and then press OK. If you wish to use nano, exit Emulationstation and then run

     nano /opt/retropie/configs/all/

  • @mitu Thank you so much again. This is why RP community is second to no one!

    Finally I made it... with no luck. I don't want to bother you. I will assume custom collections won't work for me.


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.