Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Lr-beetle-psx (x86) Super Slow



  • Hi Everyone,

    Skip to edit!

    ~~I recently wiped my x86 pi install for another issue and that has been resolved (thanks mitu!!!), but i ran into another slight annoyance with the new install and the mednafen psx core which i can reproduce on multiple computers as well as virtual machines.

    My primary focus is this computer:
    AMD Phenom ii x6
    Nvidia geforce 660
    Running Ubuntu 18.10 64 bit

    The specs are way more then enough to handle this core and psx emulation in general, but no matter what setting i try Default, as low as i can get them, or even maxed it runs at exactly the same speed which is about 5-10fps while normal is some menus. This was not a problem before i wiped it, but the core was recently updated as i found out.
    Also i cannot load ANY squaresoft game saves (.srm). It loads it in the menus of each game the screen goes black and the intro/menu music just plays...for 3 hours probably more if i let it go. Retroarch continues to function when the screen goes black.
    I mostly tested this with final fantasy 9 disk 3 which is what i was meaning to continue playing.

    The old core version that i used i believe was this, but i may be wrong:
    1.75 - Beetle PSX HW 0.9.44.1 e58fe03 filesize 7.0mb

    The one that is currently available from source and slower then heck is:
    1.75 - Beetle PSX HW 0.9.44.1 445c913 filesize 7.6mb

    Pulled from retroarch while running and filesize is from the .so file. Ive actually swapped these two and it made no difference which was strange.

    Im wondering if anyone might have an older version that perhaps i might have used, or if theres any how-to on compiling an older core?

    In the meantime i can just hook up my pi and continue where i left off, but would like to eventually figure this out for a complete all in one bedroom setup as the pi is the living room machine!~~

    Edit: Found some information on the retroarch forums regarding vsync and Nvidia drivers which causes slowdowns so i disabled it...sure enough everything runs normally!

    As for issue two now the only game save i cannot load on my AMD computer is final fantasy 9 disk 3...Whats really really weird is that using the same EXACT build of retroarch, beetle, my save and iso on both computers the save will not load on the AMD machine, but it will load on the intel laptop with integrated graphics.
    I compiled both core and retroarch from source at the same time then copied the iso as well as save from the amd computer and tried it out and well this is the result.

    If anyone has an AMD rig it would be nice if you could test out this save for my sanity:
    link text

    If you have an intel cpu im pretty sure the save is golden...strikethrough text


  • Global Moderator

    @Parabolaralus Are you using the prioprietary Nvidia drivers or the nouveau (open-source) driver ? What video driver are you using in RetroArch ?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.