Please do not post a support request without first reading and following the advice in

Arcade controllers now working?

  • Just recently, I built an arcade machine, running RetroPi. It originally worked using a regular USB controller. Idk, when I connected the arcade adapter (which I soldered the buttons and joystick onto it), next, i put in the controls for it, X, Y , A, b, all that stuff, but when i booted up a game, it didn't react to any button i pressed, except for right shoulder, and bottom left of the joystick? And also, the button that was that right shoulder, was doing the button for B.... yelp?

    • list item

  • Global Moderator

    Please add more info about your system, as requested in

  • It has an old dell monitor don't know exactly what type), model B, version 4.4,built from an SD image, have 2 encoders (Zero delay easyget encoders) (connected which have 8 buttons, and a joystick connected to each encoder. No error messages, I didn't use any guides, figured it myself. And I have an average 5v phone charger powering every except speakers, and the monitor.

  • I am having the same issue. I just got around to setting up my machine that i have been working on. Download retropie watched a few videos and then set it up. The pi started up fine and the setup screen appeared and i did what it said. I am using a arcade joystick controller you get from amazon. Everything set up fine and then once i got into a game no controls worked. I can plug in a keyboard and then that works but the arcade controller will not. Any help would be great thank you.

  • Global Moderator

    @carranz Please add the same details as requested - What kind of controller you have - model, make ? Is it recognized in Emulationstation ?

  • Global Moderator

    @owld Seems like your controller might be wired incorrectly. Use the command line and test your controller using jstest /dev/input/js0 and jstest /dev/input/js1 and check if the buttons/joystick are correctly recognized - see for how jstest works.

  • @owld Which SD image did you build it from? Only the official one from can be supported here, because third-party images could be configured very differently (many are messed-up) and produce unpredictable problems.

    If you're using a third-party image, please re-install with the official one.

    In addition to what @mitu said, if you have two identical zero delay encoders, you'll have to wire them exactly the same, because both will use the same configuration file named after them in the directory /opt/retropie/configs/all/retroarch/autoconfig.

    Furthermore, only the first controller of both should be configured in Emulation Station, because only that controller can use the "Hotkey" button for special functions (like "Hotkey" + "Start" to exit most of Retropie's emulators).

  • @mitu Thanks for the reply. I am not sure what the controllers are i bought them like 3 years ago. i just ordered and new EG STARTS Zero Delay USB Encoder. This way i know i can wire the buttons and joystick up correctly. I did download the image from this page. i am also using a pi 3 B+. I just got a new one yesterday because i shock mine old one with static.

  • Global Moderator

    @carranz I can give you the same advice as before - try using jstest to see if the controller(s) are detected and the buttons/joysticks are registered by the OS. Maybe the controllers are registered an keyboard inputs ? You can run

    cat /proc/bus/input/devices

    and check how are they registered (keyboard or gamepad).

  • Thanks for all the help. the new piece was the key and now the controls are working!

  • @carranz Good to hear, thanks for reporting back.

  • Thank you! I will try!

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.