Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Updates screwed controller config



  • Hi all,
    FYI my system is:

    System spec below:
    Raspberry Pi 3 Model B
    Raspberry Pi 2.5 amp PSU
    SanDisk 64GB SD card
    4 x Logitech F710 Wireless Controllers
    1x 4 port USB 2 Hub
    1 x Logitech Wireless Mouse and Keyboard
    O.S. RetroPie 4.4 with most recent updates

    Just thought I would apply the latest updates as it had been a few weeks. (Thank goodness I backed up first) did the usual:

    1. Backed up SD card
    2. Updated Retropie setup script
    3. Selected install updates
    4. Selected to update the underlying kernel
    5. It looks like it installed quite a lot of updates.
    6. Eventually returned to menu saying updates completed. (Wasn’t able to use any of my controller buttons to select OK. Had to resort to keyboard)
    7. Navigated menu and selected to reboot the Pi.
    8. On restart as with previous updates got prompted to enter my username and password. Did that then went into Radpberry Pi setup to fix the auto login. Strangely I was prompted to change the Pi accounts password.
    9. Restarted again to confirm this worked.
    10. One Pi has booted again went to press start to bring up the Emukation Station Menu and got nothing. Tried all different buttons till I pressed on my left analog stick and up comes the menu.
    11. Managed to get in and start a game and found controller config all screwed up. D pad still seemed ok.
    12. Cleared the controller configs and restarted the Pi then went to reconfigure the control noticed it now regards buttons A B X Y as north south east west.
    13. Reconfigure went ok till I got down to the triggers and like it had in a previous update something changed with a driver (xpad) from memory which causes triggers when pressed to be seen as an axis.

    Anyone else had these and any other issues. Have rolled back to my backup for now.

    Thanks,
    Dwarfboysim


  • Global Moderator

    Thanks for reporting this, it would have been useful to copy the update log from $HOME/RetroPie-Setup/logs so we can take a look at it. It looks like the same problem with the xpad driver being overwritten by a kernel update, everything else seems ok - the ES input configuration dialog was changed in the new ES version so the new ABXY icons are different and the - usual - systemd update will reset the auto-login in Raspbian.

    You can try updating without the OS/packages upgrade - so you only update your RetroPie components - and see if you still get the issues with the controller being unresponsive/broken.



  • Hi,
    Funny you mention that. I performed the same update on my second Pi, but instead of clearing the config etc I just went in, uninstalled the xpad driver, reinstalled from source then restarted and controller seems happy again. Now putting the scraper through it’s paces.

    Question what is the systemd option you were talking about?

    Dwarfboysim


  • Global Moderator

    @Dwarfboysim said in Updates screwed controller config:

    Question what is the systemd option you were talking about?

    There is no option - when it's updated, it will reset the auto-login settings in Raspbian (and RetroPie):
    https://retropie.org.uk/docs/FAQ/#why-emulationstation-doesnt-start-automatically-after-an-update



  • I had something similar happen to me after an update a few days ago. My controller config was hosed and the start/select buttons were inoperable. This left me with no way to shutdown cleanly or any ability to bring up the menu required to remap it. I plugged in a second controller and was able to get reconfigured, but I found the 'trigger' buttons on this controller were now no longer detected. (First time i have had this happen with this stick.) I'll probably have to reinstall the xpad driver, too.



  • Following up - I did a reinstall of the Xpad driver (removed and then installed) and it fixed my triggers, too.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.