Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Need help making a custom resolution of 1920x480



  • I have been running 1920x240 @120Hz successfully with Black frame insertion enabled on SNES and Arcade emulators. However, for some reason games just started flickering with it enabled, no configuration in retroarch was changed, threaded video is disabled as well. I tried switching the SNES emulator core from lr-snes9x 2010 to lr-snes9x but I'd still get flickering. lr-snes9x2005 and 2002 don't have the flickering but the audio quality is crap compared to the other emulators. What is so weird about this is "black frame insertion" was working for quite awhile in lr-snes9x 2010 but then games just started randomly flickering with "black frame insertion" enabled. Not all games flicker in the same way, some are more severe and constantly flickers like Kirby's Dream Land 3 and Yoshi's Island. I tired overclocking my Raspberry Pi 3B+ yet the flicker still happens. Sega Genesis runs fine with no flicker, so the only platform right now having problems with the flicker is SNES and Arcade. Once again, SNES use too work perfectly for a while with absolutely no signs of flicker with black frame insertion enabled, but then I just started having problems with it. I even swapped my Raspberry Pi 3B+ for a new one and even did a fresh install yet the SNES and Arcade emulators still didn't work as they use too. My only choice now if I want scanlines is too play @ 480p with a scanline filter, the only thing I hate about the scanline filter is it's much dimmer than true 240p. So with that, how do I create a custom resolution of 1920x480 60Hz? My current settings are

    hdmi_timings=1920 480 60 6 0 0 0
    hdmi_group=2
    hdmi_mode=16

    However, the custom resolution doesn't show up when configuring the emulator launching options.


  • Global Moderator

    @Lumbeechief081 The Runcommand launch menu uses the tvservice utility output to display the video modes.

    tvservice -m CEA
    tvservice -m DMT
    

    Can you run those commands - from the command line - to see if your resolution is listed there ?



  • I ran those 2 commands but my custom resolution does not exist. Did I use the correct hdmi_timings?



  • @mitu The 240p works and those timings are 1920 1 48 192 240 240 1 3 10 8 0 0 0 120 0 75170000 1.
    What would the timings for 1920x480 @60Hz be?


  • Global Moderator

    @Lumbeechief081 I don't have such contraption to test, sorry, but take a look here and here for an explanation on what those numbers are and how they can be generated.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.