Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

WiFi Problems



  • Hi guys,

    I need some help. So this is my problem, I have the raspberry Pie 3 with RetroPie completely set up except for the WiFi. I've been reading around the forums and the most common solution was to change your keyboard to US. I did that, and I know for a fact that I am entering the password correctly, but every single time I try to connect it tells me "Unable to connect to network." Now I did however find that I can connect to this random open network around me just fine so I know that the WiFi works. I don't know if maybe there some settings that I could change in my router or something else because for some reason its not connecting to my home network.

    Also I don't know if this helps but my router gives off to signals, one is a 2.4ghz and the other is a 5ghz. The 5ghz one doesn't even show up in the joinable networks. Also I did set my WiFi country already and timezone.

    Anyway that's my issue, please help me.


  • Global Moderator

    @FlashFlood2864 Are you sure your Access Point doesn't have some MAC filtering set up, so only known clients can connect to it ? The 3B model only knows 2.4Ghz, so it's normal to see only the corresponding SSID.

    EDIT: there is also an automated mode to configure your WiFi, by adding the necessary information in a text file and copying it on the sd-card - https://retropie.org.uk/docs/Wifi/#connecting-to-wifi-without-a-keyboard-raspbian-stretch.



  • If you can not connect your Raspberry Pi 3 to your home wifi connection, it could be that your home wifi's 2.4 ghz connection is on a wifi channel that has too much interference/noise.

    A situation to this could be that many other people who have wifi in your area might use the same wifi channel for their own home network. Try changing the 2.4 ghz wifi to a different wifi channel in your Router's administration. This also specifies for a 5 ghz wifi signal as well.

    (Notice you might need to log with the admin account and password given by your ISP to access the Router admin gui to change the wifi settings for the 2.4 ghz channel).

    My brother who also has a Raspberry Pi 3 experienced that his home wifi connection would not even show up on his Raspberry Pi with RetroPie and that was solved after i helped him with changing to a different wifi channel.



  • Just want to say thanks to you guys, I figured it out. I ended up resetting my router to the factory defaults and once that was all said and done it connected instantly. I think my brother messed something up with the mac address or something, but that doesn't matter anymore. Thanks again, next stop super Mario bros :D



  • @FlashFlood2864 That's good news. Your welcome. If you get any problems with your wifi connection in the near future, you can try changing the wifi channel in your Router's administration.

    Being on a wifi channel chosen by your Router is not always feasible and could decrease the wifi's signal if there are too many wifi network's using the same wifi channel. The Router might have a built-in wifi channel tester. :-)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.