Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Amiberry - Change of Filename Stops Game Working



  • Hi, I recently renamed all my .LHA ROM files back to their original filenames so that I could scrape them. I successfully scraped them but now some of them don't work. They come up with a WHDLOAD not found error in AmigaDOS.

    Can anyone shed any light on why this is happening?



  • @George-Spiggott

    Have you updated Amiberry recently?

    If so click on “download xml” button under the paths tab in the GUI, this may solve the problem.



  • Yes I'm using Amiberry v2.25. I have clicked on download xml as you suggested but it has no effect.

    As an example the file "Xenon_v1.2_0399.lha" bring us the error "WHDLoad: Unknown Command WHDLoad failed returncode 10" in AmigaDOS. If I rename that file "Xenon.lha" (using my PC via my home network) then reset retropie the game appears as Xenon in the Amiga games list and works fine. I can rename games as a temporary fix but I would like to keep the original filenames now that I have a functioning scraper so that I can update games if needed.

    I also have an ongoing issue with some games where the WHDLoad Autobooter brings up an error that "Volume DH0 is write protected" is there an existing solution to this?



  • @George-Spiggott

    Hi,

    This was posted on the Amiberry Facebook page, see below. It appears to be the issue you are having. I assume, but don't know for sure, that the orginal file names Xenon.lha works because you set it up prior to the update. Now you are trying to run Xenon_v1.2_0399.lha on the updated Amibery you are getting the error when it is trying to set up WHDload for this filename.

    The second option outlined below is to manually copy the WHDload file that is needed - you could try that.

    The issue with DHO being write protected could be related to retropie permissions for the folder that DH0 is kept in, this also could be linked to why you cannot downlaod the download.xml file.

    What permissions are set for the Amiberry emulator folder?

    RetroPie users:
    There's a known issue from RetroPie's side regarding the upgrade to the latest Amiberry version (the "whdboot" directory is not updated as expected, leading to one file missing from there - "WHDLoad"). If you run into this problem, with boot errors mentioning "WHDLoad: command not found" inside AmigaDOS, the solution is simple:

    • Use the "Download XML" button in the Paths Panel, inside Amiberry's GUI. This will download any missing items and fix the issue. You need an active internet connection for this to work.
    • Alternatively, just copy the "WHDLoad" Amiga executable in the "whdboot" directory of Amiberry, so it can be found. You can just grab the latest one from the official release (http://whdload.de/), exctract the LHA and copy that file only.

    This should be fixed soon from RetroPie's side, as it's an issue they are aware of. Until then, please use the above workarounds.



  • I’d like to add that at the moment, if you rename the LHA files they will no longer be picked up by the internal database, but should work on a fall back mode (the old booter)

    I am going to look at having hash recognition of files rather than filenames in the future though.



  • Is there a way to clear the database? If I uninstall and then reinstall Amiberry will that help?

    It's not a big deal to me at the moment to rename files back but going forward I think it will be of benefit to me to keep the original filename format.

    Thanks for your help.

    How do I manage the permissions on the retropie folder?



  • @George-Spiggott clear the database? What do you mean by that?

    It’s an XML file included with Amiberry and it’s essential to get the fast-loading everyone now enjoys.



  • @HoraceAndSpider

    Your previous post mentions an 'internal database'. Is it possible to edit the .XML file manually so that the booter looks for the longer filenames? Or are my short filenames (e.g. Xenon.lha) being picked up by the old booter? If so what filename is the .XML file looking for?



  • PROBLEM RESOLVED!

    I tried a full reinstall (I uninstalled Amiberry, rebooted, deleted all remaining config files, rebooted, reinstalled Amiberry from source) and this solved the problem. All my games (so far) now load with their verbose filenames. It even solved some, but not all, of my problems with games giving "Volume DH0 is write protected" as an error.

    Thanks for all the help.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.