Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

lvl0: Error creating SDL window



  • My Pi3 running EmulationStation was running fine, but I did an update of all installed packages over the weekend. Now, after the RetroPie splash screen, as EmulationStation is trying to load, I get dumped back to the console with this error:
    "lvl0: Error creating SDL window!
    Could not create GLES window
    lvl0: Renderer failed to initialize!
    lvl0: Window failed to initialize!"

    The console is then locked up at that point, although I can still SSH into the Pi and issue any commands I want. I've tried a firmware update and a rollback as I've found those as solutions, but neither worked for me.

    I know I can download a fresh image and just start from scratch, but I have a full SD card and backing it up and restoring it later would be a pain. Are there any other steps I could take?

    UPDATE
    I ended up grabbing a fresh image and installed it anyway. Then it happened again! And that's when it occurred to me...it happened right after I dropped GPU memory down to 32mb, where it had been previously. Something must have changed to no longer make that setting allowable. Thing is, the GUI for EmulationStation exhibited numerous glitches (e.g. the menu was made up of empty rectangles - there was no text) after going back up to 128mb. I had to max it out at 256mb before those problems went away.

    Anyway, I just thought I'd share what I discovered as I couldn't find another post mentioning a problem with dropping the GPU RAM and EmulationStation refusing to boot or work properly.


  • Global Moderator

    @etownAndy The default RetroPie image would increase the GPU memory - ES would not be able to run with such low GPU RAM. Did you use the RetroPie image to install or a Raspbian image ?



  • I hadn't changed the setting (maybe I was wrong and it was 64? But it was lower than default because I saw a post that suggested doing that for emulators to run better). Regardless, the setting I had worked until I did an update. When I installed the fresh image, one of the first things I did (out of habit) was to lower the GPU RAM again. That's when I noticed this issue was related to that. But it still doesn't really explain why I have to crank it up to the max to avoid display glitches in ES.


  • Global Moderator

    @etownAndy OK, so you lowered the GPU RAM - because you saw a post suggesting that. The updates to packages in RetroPie do not modify your config.txt to increase/decrease your GPU RAM.



  • I don't think you're following me. Let me try again :)
    I had been running with a reduce GPU RAM setting. If 32mb would never have worked, it must've been 64. Regardless, all was well.
    I did an update of all packages a couple of weekends ago. Then I got the error. I hadn't changed the settings immediately prior (or after) the update, nor am I suggesting the update changed my settings.

    But regardless, the only way ES gives me an uncorrupted display is to go to the max 256mb setting, which I KNOW I never used to use on my Pi3.

    Not looking for a solution as this will work for me, I just wanted to share that something must have changed since the lower setting worked fine until a recent update.


  • Global Moderator

    @etownAndy What has changed was the ES version - which was bumped recently. And while it may have worked for you with 64 RAM in the past (I don't know how) - this was never something that was tested or recommended, see https://retropie.org.uk/docs/Memory-Split/.
    You didn't mention what Raspberry Pi model you have - are you using a Pi 1/0 ?



  • I know this topic is pretty old but I just had this happen to me. It happened because of a conflict in RetroPie auto start. I had manually entered a command line to auto start and then later chose the auto start option in RetroPie setup. Seems the two didn’t work well together. I resolved it by getting back to RetroPie setup in command line and deleted the auto start line. I’m definitely a noob so I apologize if my terminology is wrong. But I’m learning. Hope this helps someone else.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.