Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Stella configuration for Atari 2600 games



  • Pi Model or other hardware: Raspberry Pi 3 (RPi3) Model B Quad-Core 1.2 GHz 1 GB RAM
    Power Supply used: 2.5A (the power supply came with this kit: https://www.amazon.com/gp/product/B01C6Q2GSY/ref=oh_aui_search_asin_title?ie=UTF8&psc=1)
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): retropie-4.4-rpi2_rpi3.img
    Built From: (Pre made SD Image on RetroPie website, Berryboot, or on top of existing OS etc.. - please provide the filename of any image used): NOOBS_v3_0_0
    USB Devices connected: USB thumb drive for ROM's
    Controller used: Keyboard, mouse, two Buffalo SNES controllers, one Atari 2600 joystick controller (all USB)
    Error messages received: No error
    Log found in /dev/shm/runcommand.log (if relevant):
    Guide used: https://retropie.org.uk/docs/First-Installation/
    File: (File with issue - with FULL path)
    Emulator: (Name of emulator - if applicable)
    Attachment of config files: (PLEASE USE PASTEBIN.COM FOR LARGE LOGS)

    Problem: I would like to play Atari 2600 games. I have a Atari USB joystick and a Daptor 2600 adapter
    (http://www.2600-daptor.com/). The default emulator for Atari 2600 games is lr-stella, but I can't get it configured correctly. When I configure the input as instructed (https://github.com/RetroPie/RetroPie-Setup/wiki/Atari-2600) the fire button actually restarts the game instead of firing. I contacted the maker of the Daptor 2600 and he suggested using the stella emulator instead of lr-stella. I installed the Stella emulator, but when I try to reconfigure Atari 2600 games to use it the only option I see is lr-stella. No plain old stella.

    I'm stuck. Any advice on getting this to work?



  • @TheSausageKing when you select a game and the grey box pops up saying “press a button to configure” press some buttons. In there change it from lr-stella to stella.



  • Then you need a keyboard and mouse. Press tab on the keyboard. (Dont need a mouse but 1000 times easier with one) Go the the controller part and configure your controllers s buttons to do what you want.



  • @TheSausageKing I don't think Stella is installed by default. Will probably need to add it through RetroPie setup.



  • @quicksilver Correct. lr-stella is installed by default. I found the command line to install stella (sudo apt-get install stella) and it appears to install without problem. However, when I try to configure stella as the default emulator for Atari 2600 games as @edmaul69 details above the only option is 'lr-stella,' no 'stella.' I can't designate 'stella' as the default. I wonder if I need to uninstall lr-stella first for some reason?



  • @TheSausageKing Why did you install in that way? Why didnt you install using the retropie setup script? If you install using the retropie setup script it will show up as an optional emulator in the runcommand menu.



  • @quicksilver I did use the "official" Retropie setup script. As far as I know I did not deviate from it at all. lr-stella was the default (and only available) emulator selected the first time I selected an Atari 2600 game for play. I'm trying to get stella as an option but haven't figured out how yet.



  • @TheSausageKing said in Stella configuration for Atari 2600 games:

    I found the command line to install stella (sudo apt-get install stella) and it appears to install without problem.

    You installed stella from the command line. The commandline is not retropie setup.

    "The conventional way to update RetroPie and install new features is through the setup script.

    The setup script can be accessed from the RetroPie menu in emulationstation.

    It can also be accessed from the terminal with sudo ~/RetroPie-Setup/retropie_setup.sh"

    That excerpt is from: https://github.com/RetroPie/RetroPie-Setup/wiki/Updating-RetroPie

    So, first navigate to the retropie menu in emulation station. Then go to Retropie Setup. Then update the retropie setup script. Then go to manage packages. Stella should be under optional packages I would think.



  • Worked exactly as you described. Thank you, sir! You are a gentleman and a scholar!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.