Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Mupen64Plus - No sound in Rareware games (non-libretro)



  • I'm able to run most N64 games with no noticable problems using non-libretro Mupen64Plus, but when I try to play any of certain games by Rare with GlideN64, gles-N64 or gles2Rice, no sound plays although the games work otherwise. The sound in these same games works fine with lr-mupen64plus, and the sound in all of my other games works fine with non-libretro Mupen64Plus.

    This occurs on at least the following games:
    - Banjo-Kazooie
    - Banjo-Tooie
    - Donkey Kong 64
    - Diddy Kong Racing
    - Jet Force Gemini

    Using the following setup
    - Platform: Pi3A+
    - Built from: RetroPie 4.4 installed over NOOBS Raspbian
    - Emulators: Mupen64Plus - GlideN64, gles-N64 or gles2Rice (Updated from source on March 13)

    With the following overclock settings (actively cooled with heat-sink and fan, consistently runs N64 at <45 degrees C):
    - gpu_mem=256
    - arm_freq=1550
    - gpu_freq=550
    - core_freq=550
    - sdram_freq=500
    - sdram_schmoo=0x02000020
    - sdram_over_voltage=2
    - over_voltage=6



  • @Ashrill If you have most n64 games running well then you are doing about as well as can be expected. Audio issues are the biggest problem I have faced trying to get n64 roms working, usually the audio gets completely pooched after trying to boot some games with certain emulators, then I have to do a jig-n-shuffle resetting audio to default an re-forcing hdmi audio; n64 is just a ****ing pain.

    That being said, your overclock settings look a tad high. I am no expert on overclocking though, I have been slowly ticking up the settings and testing the system as described by quicksilver in this thread https://retropie.org.uk/forum/topic/21519/opinion-on-overclock-settings/4

    Were you having the same issues with those games prior to overclock? With an unstable overclock you risk corrupting data on the SD card



  • @Ashrill If the audio works for some games and not others, I think that this may be fixed by an option in mupen64plus.cfg @ AudioListToAudioPlugin = False, if you don't remember changing then it is off by default. That is all I can think of for sound working, and sound not working.



  • @Ashrill audio works fine for me in those games. In fact I don't think I have played an N64 game on my pi yet that didn't have ANY sound. Can you please post more infor about your setup? Specifically how audio is configured on your system? Through HDMI? 3.5mm audio?

    /opt/retropie/configs/all/autoconf.cfg
    

    Try changing mupen64plus_audio to "0"



  • @Efriim I had a look at the file and that option was already turned off.

    @GoldManSex778 These issues were still happening before the overclock, and it seems stable based on the doom 3 test.

    @quicksilver mupen64plus_audio was already set to 0. This was through HDMI, which works for all other games I've tested, though I did also plug in some headphones when I initially saw there was no sound and there was still no sound through the headphones. Sorry for not including this information at the start.



  • @Ashrill a couple things to try:

    Try on a different tv, try using the mupen64plus binary version, try a different rom source.

    We need to narrow down hardware issue vs software. It's pretty odd that it's only affecting some games. Are you using a retropie image that you downloaded from here or is this a 3rd party image?



  • @quicksilver

    I've just tested with a new TV and with the binary installation and get the same result as before.
    I installed Retropie using these instructions, on top of Raspbian Stretch installed through NOOBS.

    Using roms from a different source seemed to make no difference (at least for Diddy Kong Racing and Banjo-Kazooie), testing both a new USA rom and a PAL rom. All roms tested still had working sound when using lr-mupen64Plus, however.

    I incidentally noticed while doing some more testing that Mario Kart 64 and Paper Mario also don't have sound when Controller #1 isn't plugged in, but the games mentioned in the OP still have no sound regardless so I'm not sure that's related.


  • Global Moderator

    @Ashrill Do you have a DS4 controller ?



  • I don't know.
    My default sound settings, from Emulation Station
    Audio Card = Default
    Audio Device = PCM
    OMX Player Audio Device = Both

    Try updating mupen64plus,

    there are some audio settings in both, raspi-config and retropie setup, that you could try messing with but you may break the audio all together youll just have to find the right setting again.

    audio wont work at all for me without adding this line to my config.txt
    dtparam=audio=on
    I think I remember going without it, but I don't know how I set it up then.

    Maybe try a higher GPU Memory split.



  • @mitu No, I've been using a logitech F310 gamepad


  • Global Moderator

    @Ashrill Can you post an emulator log ? Start the game - notice that you don't have any sound - then exit the game and upload the /dev/shm/runcommand.log to pastebin.com, maybe we can spot the error.




  • Global Moderator

    @Ashrill It seems you're running with the sdl-audio plugin - can you try switching to the omx plugin and see if that makes a difference ? Modify /opt/retropie/configs/n64/mupen64plus.cfg and change the AudioPlugin configuration to

    AudioPlugin = "mupen64plus-audio-omx.so"
    

    then boot up again a game that doesn't work.



  • @mitu Thankyou! That seems to have solved the problem. Would there be any reason to switch back to SDL for some games or is OMX just generally better?



  • Why did SDL audio not work?


  • Global Moderator

    @Ashrill Franky I don't use N64 emulation that much, so I'm not familiar with the inner workings of the audio output in Mupen64Plus. The SDL audio should work - as it works for most people -, the only difference in your config is the manual installation. You could play with alsamixer and aplay to check your sound card options/settings, but since you're only using HDMI and not an USB/external sound card, it shouldn't make a difference.

    Check the default volume on the sound card with alsamixer, maybe it's actually close to zero and, while the lr can use alsa directly to control it, maybe the SDL audio plugin in Mupen64plus doesn't.

    EDIT: is there any reason you used the NOOBS option to install RetroPie instead of using the RetroPie image ? You can find one that supports the 3A+ at http://files.retropie.org.uk/images/weekly/retropie-4.4.8-rpi2_rpi3.img.gz .



  • @mitu I originally used this pi as a portable general purpose machine and didn't want to have the hassle of having either a separate SD card for Retropie or having to fiddle around getting my data and settings back to normal after re-imaging.
    alsamixer was set to 100, so that doesn't seem to be the issue - OMX seems to be working fine so it's no problem if you're not sure about the cause of the SDL-audio problem.



  • @mitu
    Thanks for the new commands, this one is kind of cool.
    alsamixer shows only one card:
    bcm2835 ALSA
    while lowering the default volume does make it quiet, the libretro emulators are also quiet.

    Noobs is an easy way to have a dual-boot and manage startup. But using retropie there isn't much of a reason to dualboot. Retropie should have a startup option to disable or select how you want to use your device.



  • @Ashrill just be aware save states will not function when using omx as the audio plugin. Also the default volume is insanely loud and can't be adjusted as far as I know.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.