Please do not post a support request without first reading and following the advice in

  • Pi Model or other hardware: Raspberry Pi 3
    Power Supply used: Officieal power supply
    RetroPie Version: 4.4.1
    Built From: Official Premade Image
    USB Devices connected: Logitech USB wireless keyboard
    Controller used: WIi U pro
    Error messages received: n/a
    Emulator: This happened on FBA and psx running through emulation station

    I’m at work now so couldn’t get the other info

  • This happens to me, when the gpu memory split is too low.
    There is an advanced setting in raspi-config for the memory split. You will need a keyboard to change it, it will read what it is already at, 256 or 320 or 384 is a good amount, but I guess any positive integer above 256 will work.

    If that doesn't help, sometimes games will close when I transferred them incorrectly or if I am transferring something while playing. You could try reuploading to the pi but there is no guarantee it will fix anything.

  • @Efriim

    As usual you are a great help thanks a lot Efriim. I will try that out soon as I get home from work

  • @misticknight can I ask if you have your Wii U Pro Controller connected via the on-board bluetooth? I have 4 of these controllers and initially had issues with 'ghost' inputs, such as getting randomly kicked out of games. This was solved by buying a bluetooth dongle and disabling the on-board bluetooth by adding dtoverlay=pi3-disable-btto /boot/config.txt.

  • @omen_peter

    Hey, yes I do have it connected with on board Bluetooth 😬to be honest I didn’t have these problems with my DualShock 3 controller but I was using the WUP controller last week fine it wasn’t until last night/today this happened. I’ll try Elfriim advice for now if it doesn’t work I’ll just remove the Wii U controller and see from there

  • @misticknight yes absolutely try @Efriim solution first. I hope it solves the problem! With regards specifically to the Wii U Pro controller, I'm 99% sure it is the onboard bluetooth. I know first-hand how frustrating this issue is. I had to restart Final Fantasy 6 3 times before I worked out what was happening!

  • @omen_peter

    Just spend 30 minutes on SotN after changing the memory split so hopefully that did it cause before that it seemed to exit after 5 minutes max. If it happens again I’ll just remove the WUP controller and use my PS3 control instead (which is horrible in comparison but I don’t want to buy a 3rd party BT dongle just yet)

  • Spoke too soon just crashed now after coming back to it and playing for 5 minutes. Goodbye Wii U pro controller :(

  • @misticknight
    Sorry I couldn't help, maybe there will be an update. I use a DS3, theres a new controller driver for it called the sixaxishelper. It loses the vibrate on connect effects, but it allows you to use the bluetooth for other controllers at the same time. It also fixed an issue I had with the button map not resembling the same controller when it was plugged in.

  • @Efriim

    thats okay thanks for trying :) and the DS3 works fine as is i just moved onto Wii U Pro controller cause its much more comfortable and lasts longer but what can i do. DS3 for now.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.