Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Amiberry - lha - problem with naming



  • Hi all,

    i'm using the latest version of amiberry.
    When i try to run "Apprentice_v1.3_2288.lha" i'm getting the error:

    WHDLoad: Unknown Command WHDLoad failed returncode 10

    but, if i rename the game in "Apprentice.lha" it start correctly. Why?

    I have also tried to download and update the xml list from the amiberry path tab

    I have checked the whdload_db.xml and i have found different entries for the game Apprentice, and one of this have the name "Apprentice_v1.3_2288.lha". Why this game doesn't run with this name?

    I have a second game called "GarfieldAWintersTail_v1.0.lha". This works perfectly named in this way and it works also if i rename it in "Garfield.lha".

    Please help me, i don't understand the relation with the name of the game

    Thanks


  • Global Moderator

    Please add more info about your system, as requested in https://retropie.org.uk/forum/topic/3/read-this-first.
    What version of Amiberry are you using ?



  • I had this exact same problem. I solved it by reinstalling Amiberry. It resolved all of my verbose filename issues and a few "Volume DH0 is write protected" errors as well.

    "PROBLEM RESOLVED!

    I tried a full reinstall (I uninstalled Amiberry, rebooted, deleted all remaining config files, rebooted, reinstalled Amiberry from source) and this solved the problem. All my games (so far) now load with their verbose filenames. It even solved some, but not all, of my problems with games giving "Volume DH0 is write protected" as an error.

    Thanks for all the help."

    https://retropie.org.uk/forum/topic/21541/amiberry-change-of-filename-stops-game-working/9



  • Retropie v 4.4 and Amiberry v2.25

    @George-Spiggott i have tried with your solution but nothing.

    1. Uninstalled Amiberry
    2. Deleted the config folder and rebooted the system
    3. Installed Amiberry from source
    4. Runned "Apprentice_v1.3_2288.lha"

    but i've got the same error.

    I don't understand why :(



  • @gerry_keys The only other thing I did was updated the XML again when I reinstalled.

    I don't actually know if deleting the Amiga config files after uninstalling helps but I deleted all of them. I was left with some empty folders that would not delete. It is possible that they are overwritten when Amiberry reinstalls but I wanted to be thorough when I did it.

    I also have a custom joypad config file that I keep in Amiberry/conf (to mitigate Amiberry's Xbox joypad issues) but apart from that my Amiberry setup is entirely vanilla.



  • @George-Spiggott first of all thanks for your support.

    Can you please send me your .xml file in order to check the differences ?



  • Sure I'll do that tonight when I have access. I updated my XML via the button in the Amiberry GUI, it isn't modified by me.



  • Many many thanks @George-Spiggott !!!

    in addition (if you have the time for me :) ) could you try to run "Apprentice_v1.3_2288.lha" and check if it works?

    Sorry for these request, the passion for the retrogaming is too big for me :)



  • If I can find a copy I will. Don't tell me where to find it here, I'll google it.



  • @George-Spiggott thankyou so much



  • Incidentally, does anyone know what the naming format is for WHDload games is, specifically what do the four digits at the end of the filename mean? What, if anything, does CDTV in the filename trigger in Amiberry?



  • I tried Apprentice with a verbose filename, it worked fine. The XML file is pretty large and I cannot attach it here. This is the apprentice entry.

    • <game filename="Apprentice_v1.3_2288" sha1="39d97b0d129136ce9afe6f0adc290ef81701f0e6">
      <name>Apprentice</name>
      <subpath>Apprentice</subpath>
      <variant_uuid>9b3892ef-8ff0-5502-9938-5fb8f64827f8</variant_uuid>
      <slave_count>1</slave_count>
      <slave_default>Apprentice.slave</slave_default>
      <slave_libraries>False</slave_libraries>
    • <slave number="1">
      <filename>Apprentice.slave</filename>
      <datapath />
      </slave>
      <hardware>PRIMARY_CONTROL=JOYSTICK PORT0=JOY PORT1=JOY SCREEN_Y_OFFSET=</hardware>
      </game>


  • @George-Spiggott thank you

    the xml entry is the same for me

    i don't know what is the problem



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.