Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Added ROMs and old ROMS disappeared



  • Hello everyone,

    I am running the Pi 3 with an old xbox 360 controller and now the latest version of RetroPi (v4.4). I was running the older version of RetroPi and normally added games to my Pi through a USB stick. I wanted to add a few more games and decided to use the Network to transfer the files over to make it a few less steps. All of the new games for the Game Boy Advance showed up, but all my old games do not appear. The files are still there and I tried backing them up and then deleting them and transferring them back over the Network. This, and also upgrading to the latest version of RetroPi via a complete format and install did not solve the issue.

    I can still only see the new games. My only guess is something happened to the actual files and there might be a permission issue?

    Anyway, I hope someone might have an idea of what I can do to get my old files to reappear. Thank you so much.


  • Global Moderator

    @Littlezero If you're fearing a file permission issue, you can always reset the ROM folders' permissions using the RetroPie-Setup menu: https://retropie.org.uk/docs/FAQ/#reset-ownershippermissions-of-homepiretropie-roms.

    What extensions are the non-appearing ROMs ? Can you give an example - system and ROM ?



  • @mitu As far as I can tell, it is only my old Game Boy Advance games. I just double checked the file extension names and noticed the new games all end with .GBA and the old ones that are not appearing end with .srm and .state. Is it possible that I have the saved game files and for some reason the .GBA game file was erased?



  • @Littlezero -SOLVED-

    So what I thought were the Game files ended up being the saved game files. I am not sure what I did but when I transferred the new games over I somehow deleted the old games. If this happens to anyone else, you can get your old saved game data back. I had my save files backed up and just started the game up and allowed the game to remake that file without my saves. I then moved my old save file over, making sure it matched the name and file extension type exactly and it worked.

    Thanks and hope this helps.


  • Global Moderator

    @Littlezero .srm and .state files are not ROMs, as you have discovered.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.