Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SSH stuff



  • Guide for using Android and Ethernet to SSH for those without keyboards.

    How to active SSH without configuration

    Import a WiFi passkey thanks @cyperghost

    Guide for using winscp to effectively upload and change permissions


    So while I was doing things to my pi trying to get winscp to use root, I altered something on my course and ssh will not enable. Using raspi-config when I enable any of the interfaces, it tells me that The SSH Server is (Blank); as opposed to Enabled Disabled.

    Solved thanks mitu

    I changed /etc/ssh/sshd_config but reverted the changes adding and removing
    PermitRootLogin without-password

    I made the unremarkable error of uncommenting one of the lines in /etc/ssh/sshd_config and not noticing.
    using sudo /usr/sbin/sshd -d game me what was wrong with my config, and I recognized it and restored the hash.


  • Global Moderator

    @Efriim said in SSH stuff:

    What script needed to be ran as $USER instead of root in /opt/retropie/?

    RetroPie-Setup lives in installation user's $HOME folder, the /opt/retropie folder is for package installation and configurations.

    That would overwrite a config as root and then not be able to access it as USER with accurate perms. Or possibly it was a symlink in /opt/retropie/configs/ that changed ownership to uid:pi, is that possible is that how symlink permissions work?

    The configs is owned by the install user and it may contain symlinks to the user's various folders under $HOME. Symlinks themselves have no permissions

    On Linux, the permissions of a symbolic link are not used in any operations; the permissions are always 0777 (read, write, and execute for all user categories), and can't be changed. (Note that there are some "magic" symbolic links in the /proc directory tree—for example, the /proc/[pid]/fd/* files—that have different permissions.)



  • @mitu
    I know I didn't get /opt/retropie and $HOME/RetroPie confused. But this neither explains why raspi-config will not enable interfaces.
    At least it wasn't the symlinks... I think.

    Would you list the uncommented lines in sshd_config for me
    cat /etc/ssh/sshd_config|grep -vE '#'


  • Global Moderator

    I don't think that the SSH error has anything to do with /opt/retropie. Start sshd in debugging the command line and see what errors you get - maybe you accidentally mis-typed anything in the configuration file or modified its permissions.

    Would you list the uncommented lines in sshd_config for me
    cat /etc/ssh/sshd_config|grep -vE '#'

    
    AcceptEnv LANG LC_*
    ChallengeResponseAuthentication no
    PrintMotd no
    Subsystem       sftp    /usr/lib/openssh/sftp-server
    UsePAM yes
    X11Forwarding yes
    


  • @mitu
    Thanks sudo /usr/sbin/sshd -d to debug helped a lot.
    It was the very first line /etc/ssh/sshd_config that had been uncommented, I noticed it wasn't in yours but it kind of blends in and I kept ignoring it for some reason.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.