Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Trouble viewing/saving screenshots



  • On Retropie 4.4, when I am playing a game, I can open the Retroarch menu and take a screenshot. It seems to take and save the screenshot. I hook my computer up to my pi through network and go to RETROPIE\configs\all\retroarch\screenshots and I can see the names of every screenshot I have. But nearly every time I try to open one and view, my computer will say that it can't read the file. Randomly (and rarely) it will let me view a screenshot. I don't know why this is happening. I am using Raspberry Pi 3 b+ and my computer is Windows 10 if that helps. If someone could help me, it would be greatly appreciated. Thanks


  • Global Moderator

    @Double_J Can you try transferring the files first on your PC and then open them ? Can you upload such an image somewhere to take a look at it - maybe RetroArch saves an incorrect .png image ?



  • @Double_J Do you use WIFI? As mitu suggested, try to copy the file to your pc first and then open them and upload such a suspicious file, so we can see if we can open it.



  • @thelostsoul I copied the file into my saved pictures folder on my PC and attempted to open with Microsoft Photos, but it says "We can't open this file." If I try to upload it here, I get an error message that says "input file contains unsupported image format" and this is what is uploaded:
    ![0_1559686109504_Mike Tyson's Punch-Out!! (USA)-190604-014344.png](Uploading 100%)
    Here is a screenshot that worked even though I did the exact same thing:
    Super Mario World (USA)-190604-014307.png
    They are both .png files



  • @Double_J I had some issues on my Linux machines with specific applications or uploads, when the file ending was not in lower letters. Not specifically with screenshots, just saying I had this experience where I had to change from .PNG to .png ending or from . jpeg to .jpg.



  • @thelostsoul They all end in .png I've tried changing them to .jpg as well, but that didn't help. I should also maybe mention that when I go into RETROPIE\configs\all\retroarch\screenshots with my PC through network, the not working screenshots show that they take up 0 KB of data, while that Mario World screenshot shows 12 KB. Also I took a bunch more screenshots and am getting better results now; more than two thirds of them are viewable, but there's still just random ones that don't work right.


  • Global Moderator

    @Double_J If the screenshot file is 0 bytes, it's obviously empty - hence the errors. For some reason, RetroArch creates the file but it doesn't save the contents correctly.



  • @Double_J Could it be that the micro sd card is broken? If you can, make an exacty backup copy on a different micro sd card with same size and if it still happens, this could be ruled out. Off course only if you have one in spare.



  • @thelostsoul Thanks for giving me an idea of what might be wrong. Unfortunately, the only extra micro SD card I have is 16 GB, while the one in my pi is 32 GB. It's not really that big of a deal with the screenshots though, so maybe sometime in the future I'll get another sd card and try that out. Thanks for the help.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.