Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Return to Castle Wolfenstein - IORTCW source port



  • alt text
    Since ioquake3 source port of Quake 3 has been created, other source ports based on the same recipe has been a possiblity and Return to Castle Wolfenstein is no exception. I have manged to build a working scriptmodule and made some optimization to the config file for IORTCW so that it works better for RetroPie.

    This port uses SDL2 dependencies

    Download scriptmodule for RetroPie:

    wget https://raw.githubusercontent.com/tpo1990/RTCW-RPI/master/rtcw.sh -P $HOME/RetroPie-Setup/scriptmodules/ports/
    

    After downloading scriptmodule, go to the experimental section in RetroPie Setup to install.

    Install time: It takes about 15-30 minutes to install.

    To play the game:
    IORTCW requires the pak files of the full game to play. Add all your singleplayer pak files (pak0.pk3, sp_pak1.pk3, sp_pak2.pk3, sp_pak3.pk3 and sp_pak4.pk3) from your RTCW installation to /home/pi/RetroPie/roms/ports/rtcw.

    For Multiplayer. Add all the multiplayer pak files: mp_bin.pk3, mp_pak0.pk3, mp_pak1.pk3, mp_pak2.pk3, mp_pak3.pk3, mp_pak4.pk3, mp_pak5.pk3, mp_pakmaps0.pk3, mp_pakmaps1.pk3, mp_pakmaps2.pk3, mp_pakmaps3.pk3, mp_pakmaps4.pk3, mp_pakmaps5.pk3, mp_pakmaps6.pk3 from your RTCW installation to /home/pi/RetroPie/roms/ports/rtcw.
    Notice. Demo version is not supported, since IORTCW requires the singleplayer pointers pak files(ex. sp_pak1.pk3).

    Notes:
    The source port downloads and can be installed from the Experimental section in RetroPie-Setup. I have made optimizations from ioquake3 config file to the wolfconfig file so that it runs best for RetroPie. The config file could maybe be optimized further. It is not possible to change video settings, since settings menu does not work. The gameplay is not as smooth as Quake3 port but it works good enough. No bugs or errors has been discovered yet. Report errors if you see them.

    What about Multiplayer?
    Multiplayer has it's own folder (MP) and it's own binary to run from where as the Singeplayer folder is (SP). As far as i have tested, Multiplayer works as good as it's Singleplayer counterpart and you can even see internet servers still running. Multiplayer config files will be located in /opt/retropie/configs/ports/rtcw-mp

    Disclaimer:
    This installation script is provided as is and has been tested to work with RetroPie. You should always have a backup ready incase anything happens with your Raspberry Pi.

    Screenshots:
    alt text
    alt text
    alt text



  • Reserved for future use:



  • Changelog:
    02-07-2019: Updated scriptmodule to include multiplayer support.
    13-06-2019: Finished scriptmodule and uploaded to github repository. Created topic on RetroPie Forum.



  • OMG mate, this is amazing, thank you for creating this brilliant port for us :)



  • @Brigane I have to agree, this has to be the best source port to get working on our RPI and it is actually easy to compile and build a working binary. Now it just needs further optimizations so that it will run even better. Hopefully as good as the Quake 3 port :-)

    Glad to make it happen.



  • Looks amazing! Does it support gamepads natively?

    I think I should try to learn how to use xboxdvr just to try these ports...



  • @ellohir I have not tried gamepads yet. I have only tried ioquake3 (Quake 3 port) and that port does work after configuring gamepad controls in the input options. The only problem is that the settings/options menu in iortcw is missing and can not be accessed as it appears to be incomplete. You will have to modify the wolfconfig.cfg file by yourself knowing what input your gamepad uses.

    I would recommend setting up xboxdrv and configure it to use your gamepad as keypresses. Xboxdrv works great for other source ports that i have tried. It works perfect with Quake 3.



  • This looks awesome! I cant wait to test it out!

    Was really hoping to that your success here might make it possible to port "No One Lives Forever". I was hoping that maybe it was made using the quake 3 engine but sadly it wasnt.



  • I just installed and transferred the .pk3 files to the directory you listed but game fails to launch and kicks me back to emulation station.

    Edit: I checked the runcommand log and it says that sp_pak4.pk3 is missing. This file doesnt appear to be apart of the installation on my home PC. Any ideas why it might be missing?

    I found an alternate source for the missing .pk3 file. Works like a charm now. Performance is very good!



  • @quicksilver Im not quite sure why it would be missing as i would think that the sp_pak4.pk3 file would be found in a normal installation. The GOG version works perfectly fine. It could be due to some patch version dependant of the source port.

    Great to hear that performance is very good as i took the time to look into optimizing the port. When you first build it, the display is not correctly scaled to full size and when you do change that, it does not run great and therefore i looked at the Quake 3 config file and made most of the same changes to the wolfconfig.cfg file.



  • Multiplayer has been added to the RTCW scriptmodule. You can now play Return to Castle Wolfenstein on servers and host your own LAN server.

    Remember to update the scriptmodule again from the download instructions.
    Then reinstall to update the same way you would install it.

    If that fails, then first uninstall RTCW from the scriptmodule and then remove the rtcw folder in "/opt/retropie/configs".

    Notice: It is not necessary to remove the rtcw roms folder, just copy the required multiplayer pak files from your windows installation or use innoextract and extract from GOG setup file.

    Enjoy. :-)



  • Sorry for making such a short update after enabling multiplayer build. I have now improved the script to make it create both a rtcw-sp and rtcw-mp config folder in /opt/retropie/configs/ports. It is only for making a much more prefined structure

    So that means in short, when installing the source port it will look like this:

    • SP config folder: /opt/retropie/configs/ports/rtcw-sp
    • MP config folder: /opt/retropie/configs/ports/rtcw-mp
    • Roms folder: /home/pi/RetroPie/roms/ports/rtcw
    • Binary folder: /opt/retropie/ports/rtcw


  • I am not sure what happened, but on my test run it appears that options menu now works so that the games settings can be changed from in-game. It didn't work earlier. Can someone please verify that they also have it working on their RPI?



  • Hey, this is awesome! Just wondering, what graphic settings are you using on your RPi? I've got it running at the lowest settings and it's playable, but doesn't look as great as the screens you're showing.
    Thanks!



  • @mpowrpi which pi are you using?



  • Cheats code doesn't work with console (ex: god, give all ...).
    How to activate them?



  • @WarC0zes There is a good chance that the option to use cheats has not been enabled or fully implemented in the source port. There is nothing in the git repo indicating that cheats can be used.

    So unfortunately using cheats is not an option. I have not tested it but maybe other people here has?



  • @tpo1990 said in Return to Castle Wolfenstein - IORTCW source port:

    @WarC0zes There is a good chance that the option to use cheats has not been enabled or fully implemented in the source port. There is nothing in the git repo indicating that cheats can be used.

    So unfortunately using cheats is not an option. I have not tested it but maybe other people here has?

    ok, thanks for the informations.



  • @quicksilver RPi Model 3 B+, with 32GB microSD



  • When using a python background music script, the music continues playing after booting the game. I'm trying to find the name of the process to add to the background music config file. Adding "iowolfsp.arm" doesn't work for me. Just wondering if anyone knows what I should do.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.