Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

fake 8Bitdo SF30 Pro, way to get working?



  • Hi,

    I made a mistake and bought fake 8bitdo controller. Now that I have it, I wonder if there is a way to get it working. It doesn't make sense to send it back.

    I can easily get it to connect, and reptropie-setup makes correct udev rule to make it reconnect on controller power on event. However, while it's connected, it doesn't help that I press any of the buttons while retro-pie is waiting for buttton A -press. The welcome screen stays there forever, saying one gamepad detected.

    Any ideas?



  • Turns out that if I connect it through USB-C cable, retro-pie sees it as xbox 360 device. But still nothing while connected via BT. It seems according to this page that in wireless mode it behaves as Switch controller. I need to start googling about it.



  • Forgot to mention retropie version. Everything is the latest, installed today, did apt upgrade, and git pull for the setup script (4.4.15). Raspi3.

    I tried putting this config in place, but no help: https://retropie.org.uk/forum/topic/8646/switch-pro-controller/20


  • Global Moderator

    Is the controller working with jstest ? Are the buttons/D-Pad/joystick registering ?



  • Thanks for pointing out jstest. I will read more about it. At first try it seems to recognize the joystick, but doesn't print out any button changes after initial text:

    $ jstest /dev/input/js0 
    Driver version is 2.1.0.
    Joystick (Pro Controller) has 6 axes (X, Y, Rx, Ry, Hat0X, Hat0Y)
    and 16 buttons (BtnA, BtnB, BtnC, BtnX, BtnY, BtnZ, BtnTL, BtnTR, BtnTL2, BtnTR2, BtnSelect, BtnStart, BtnMode, BtnThumbL, BtnThumbR, ?).
    Testing ... (interrupt to exit)
    Axes:  0:-32767  1:-32767  2:-32767  3:-32767  4:     0  5:     0 Buttons:  0:off  1:off  2:off  3:off  4:off  5:off  6:off  7:off  8:off  9:off 10:off 11:off 12:off 13:off 14:off 15:off
    

  • Global Moderator

    @ikkeT If jstest doesn't work, there's little chance it will work in ES or the emulators. Try to start it in XInput (PC) mode and test it.



  • @mitu I don't see a way to start it in such mode via BT. If it's connected via USB, it is behaving like XBox 360 controller. I assume that's X-input? With that, it works fine while on wire.

    I've been reading about Switch controller methods now, but it doesn't seem to work exactly the same way. Switch controllers (which it emulates) should work to some extend out of the box. Only some calibration issues, but this one won't act on any button.



  • If anyone recognizes this controller in picture, please advice:

    pro controller


  • Global Moderator

    @ikkeT said in fake 8Bitdo SF30 Pro, way to get working?:

    Only some calibration issues, but this one won't act on any button.

    You can try and make it work on a PC (Windows) via Bluetooth - see if it works this way.



  • @mitu I don't have access to windows in a week, but I'll try then. Thanks, good idea. ATM I have RHEL8 laptop and android phone. I'll try those too.


  • Global Moderator

    @ikkeT You can try on Linux (RHEL), but I suppose it will be similar to the Raspberry PI. I



  • This is what it looks like in dmesg, while connecting it via different means. Occationally with BT on, sometimes USB.


  • Global Moderator

    @ikkeT You forgot to link the dmesg output, I think ?



  • Yes, I forgot the actual dmesg :) Now I can't paste it, as it's classified as spam :(

    Let's try reformat:

    [   11.880638] input: Pro Controller as /devices/platform/soc/3f201000.serial/tty/ttyAMA0/hci0/hci0:11/0005:057E:2009.0001/input/input0
    [   11.880907] hid-generic 0005:057E:2009.0001: input,hidraw0: BLUETOOTH HID v0.01 Gamepad [Pro Controller] on b8:27:eb:b8:1d:86
    
    [  522.089432] input: Nintendo Co., Ltd. Pro Controller as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/0003:057E:2009.0002/input/input1
    [  522.090850] hid-generic 0003:057E:2009.0002: input,hidraw0: USB HID v1.11 Joystick [Nintendo Co., Ltd. Pro Controller] on usb-3f980000.usb-1.4/input0
    
    [  525.647783] input: Microsoft X-Box 360 pad as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.4/1-1.4:1.0/input/input2
    
    [  920.988380] hid-generic 0003:057E:2009.0004: input,hidraw0: USB HID v1.11 Joystick [Nintendo Co., Ltd. Pro Controller] on usb-3f980000.usb-1.4/input0
    
    

  • Global Moderator

    Hm, detected as hid-generic. Can you check what's the udev rule that was added ? Post the .conf file from /etc/udev/rules.d.



  • This is what retropie adds:

    pi@retropie:~ $ cat /etc/udev/rules.d/99-bluetooth.rules 
    SUBSYSTEM=="input", ATTRS{name}=="Pro Controller", MODE="0666", ENV{ID_INPUT_JOYSTICK}="1"
    

    and this I tried from one of the forum posts while looking for switch controller posts:

    pi@retropie:~ $ cat /etc/udev/rules.d/99-nintendo-switch-pro-controller.rules 
    #KERNEL=="event*", ATTRS{name}=="Pro Controller", SYMLINK+="switch-pro-controller", TAG+="systemd", ENV{SYSTEMD_WANTS}="nintendo-switch-pro-controller.service"
    #KERNEL=="event*", ATTRS{name}=="Pro Controller", ACTION=="remove", RUN+="/bin/systemctl stop nintendo-switch-pro-controller"
    
    

    Now it's back to the first one added by retropie-setup.sh.




  • Global Moderator

    @ikkeT if your buttons/inputs are not registering, then it means xboxdrv is not going to work. The 1st udev rules file is ok, it should force the device to appear as a gamepad device to the system, but I think the device might expect some kind of initialization from the system to start working.

    IMHO, at this price you should get a real 8bitdo and not a clone/knock-off. You might be able to make it work via the USB, if you convince the xpad driver to handle it (it's not handling it at the moment because it doesn't know the device).



  • The USB is rather OK, has been from the start. Only issue is that the home hotkey doesn't work. But I bought this for BT, and as I have no experience, I thought it really is 8Bitdo. I was fooled by the ebay sellers having 8Bitdo in the topic. I only yesterday found out it is not 8Bitdo :(



  • Bump!

    I got the same issue, the controllers are great and ok quality. Has someone been able to get it working? I can use it wired but when it comes to wireless won’t detect input. It does connect fine and seems to be detected as a switch pro controller.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.