Please do not post a support request without first reading and following the advice in

Black screen when i run ANY ROM and most options in setup after update

  • Hi all, I posted this on reddit but only got one comment and a bunch of downvotes for some reason. I thought I'd try here to see if I could get some help:

    I will preface this that I am a casual user and am not a programmer, but I can google, understand using command line and have held my own keeping my setup going until now.

    I have a Pi 3B+. Been using it for over a year (on 4.4 prior to this) with minor issues here and there (black screen for certain emulators, controllers going crazy etc). All have been fixable with some googling. Anyway, last night I ran some updates (driver packages, core packages, main packages, etc) because I saw that 4.5 was released and wanted to get ready. It had been quite a while since I ran updates. After doing this and rebooting, all games stopped working across all emulators. I then upgraded to 4.5 hoping it would fix whatever I managed to break but alas it did not. I ran updates again - no change. I cannot run any games nor can I go into most retropie menu options. In fact, the only thing that I can do is go into Retropie setup. I can also SSH (i never really have a need to do this though) and get to command line.

    I have been researching this and cannot find a fix. I hope someone can help me! Currently I am sitting at 4.5 with my 3B+ and have ran every update I can find in any menu, and I'm hitting ctrl-alt-delete every five minutes to reboot because my screen keeps going black after trying this thing or that.

    The one comment on reddit suggested I reinstall retroarch. I did that and nothing changed.

    *Side note about the black screen. You can type in it like it's the CLI but with no prompts or anything. It's just text that does nothing.

    I don't know how to generate logs because I've never had a need. Please help, I want to play DQ6!

  • Global Moderator

    @danield420 Please add more info about your system, as detailed in
    If you have SSH access, please provide the output of /dev/shm/runcommand.log, taken after you're trying to run a game and you get a black screen.
    Did you change any of the video settings of your PI - in particular the resolution through the Runcommand menu ?

  • Sorry, will gather that info now. I feel great shame that I didn't follow the "read this first" thread since I used to moderate a forum myself! I was just already at my wits end with this before I came here.

  • @mitu And no I didn't change the resolution, all I did was run updates etc. I remember being able to go into the options of a particular rom through what I think is the runcommand menu, but you need to do that after you select a ROM to play, right? Now if I select a rom I don't get that option, i instantly get the black screen before I would normally see the loading window which would allow me to get into runcommand (assuming I am understanding this correctly).

    Since my last post I have reinstalled Retropie and I'm still encountering the problem! Gathering your info now.

    Pi Model or other hardware: B+
    Power Supply used: Canakit 2.5amp power supply that came with the kit I purchased
    RetroPie Version Used: 4.5
    Built From: Image from Retropie website (4.3 at the time I believe when I first bought this)
    USB Devices connected: 1 USB SNES controller that came with the kit. At this moment also a keyboard and wires mouse for troubleshooting
    Controller used: 1 or 2 SNES controllers
    Error messages received: None really, everything just kind of slowly fades into a black, empty command line screen and there it stays.
    Log found in /dev/shm/runcommand.log (if relevant): See below
    Guide used: (Mention if you followed a guide): About a zillion guides I found online trying to troubleshoot. Too many to list
    File: (File with issue - with FULL path): N/A
    Emulator: (Name of emulator - if applicable): Every emulator on my Pi - NES, SNES, various Segas, NEO GEO, N64, NDS, various ataris, etc.
    Attachment of config files: (PLEASE USE PASTEBIN.COM FOR LARGE LOGS)
    How to replicate the problem: Just try to run any game or any option in Retropie menu except Retropie Setup.

    RE: logs - I'm sorry, I tried my best to get this for you but A) I cannot access the option to turn on logs (I'm not 100% sure how to even do this) since the screen goes black as soon as I run a ROM B) I am logged into my pie and trying to navigate it via SSH from this desktop and I cannot seem to find a runcommand.log. I was hoping there would be a pre-existing one or it would be enabled by default and C) Even if I did locate a log, I have no idea how to export it to a text file to include here. Any tips on this would be helpful. Meanwhile I will try to learn how to do this as time allows!

  • Global Moderator

    @danield420 If you don't have a /dev/shm/runcommand.log, then Runcommand might not work/run to produce a log when running a ROM. Did you add anything else that might interfere with it - like the joystick selection tool, or music scripts ?

    You seem to be running a P1 1, correct (B+ means Pi 1B+ and not 3B+) ?

    If you were running 4.3, then you had an image based on Raspbian Jessie, which unfortunately is out of support now (since Raspbian doesn't support it also, for quite some time).
    If you're willing to start from scratch, then use the latest 4.5 image and see if out-of-the-box the Runcommand works, then you can copy over your ROMs, saves and scraped artwork. Make a backup first - see

  • @mitu It's a Pi 3 B+, sorry for not being clear earlier. I purchased it roughly a year ago or so as part of a whole kit with a little NES case.

    Earlier today, I uninstalled Retropie then re-installed it. I did all this through the menu on the Pi itself (didn't take the SIM card out and reformat it or anything like that). Does that qualify as starting from scratch? Am I not installing Retropie on a fresh "image"? How does one completely start from scratch? Do i need to pull out the SIM card?

    I have not added anything like you mentioned. The closest thing to this is that I installed the Nintendo DS emulator.

    A little while ago I installed the "tree" feature and through SSH I ran a tree command, to help me try and make sense of how this all works (this is the deepest I've ever gone in messing with my Pi). Anyway, I see dev>shm and then there's nothing nested in shm. It appears to be empty.

    I think I need to read up on exactly what Runcommand is, what it does and how to use it. I'm kind of struggling with this area as I've never really had to use it since I bought this. I thought it was a simple thing that you just hit a button as the game was loading, and you got a few options like "choose your emulator". I've had to do that in the past when games ran like crap or kicked me back to the main menu/didn't load etc. Am I misunderstanding what Runcommand is? If not, then it used to work for me. Is it possible for me to manually add a runcommand.log file through Windows, which could maybe enable the feature? I'm able to access folders on the PI from my desktop (it's how I put ROMS on the Pi). I tried searching Windows explorer but could not find the file.

    Side note - I had to create and manually add an autostart file after re-installing Retropie earlier, if that info is useful.

  • @danield420 not sure if you did this already but to start from scratch you will have to format your sd card

    Then download the RetroPie 4.5 image, flash to your sd, and ect

    Sucks starting over again but just has to be done sometimes.

  • @dan18774 I ended up doing what you posted and started over. Everything is mostly working now! In some cases better than before. I need to do some tweaking, and so far in my testing i'm finding that Sega Megadrive games give me a black screen but I think I can figure that out since it's happened so many times in the past. Thanks!

  • @danield420 cool glad things worked out! Hey i suggest you do backup once you get your image setup how you want it. Then if something happens you don't have to start from scratch.

  • @danield420 well the black screen could be a bad rom or possibly a missing bios file. Sure there are other factors for the balck screen i'm still learning myself. This RetroPie Github page has helped me so much .

    Or make another topic and i'm sure someone can help you solve the problem if you didn't already on your own.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.