Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Mouse problems in Duck Hunt



  • Pi Model: 3b+
    Power Supply: Cana Kit 2.5a 5v power supply
    Retropie Version: 4.5.1
    Built From: Pre-made Image
    USB Devices connected: Microntek USB Joystick, wireless keyboard dongle, USB mouse
    Controller used: Microntek USB joystick and a USB mouse
    Error messages received: none
    Emulator: lr-fceumm
    How to replicate problem: Open up duck hunt with lr-fceumm emulator, with optical mouse and joystick and button set configured. Start duck hunt and when select button is pressed a cursor like thing pops up, but moving the mouse doesn't move it, and I cannot use any button to shoot the gun. I have made sure the mouse works. The controller is configured as a zapper in retroarch. The mouse works but the buttons on it do not, so maybe that is the problem. But I have other buttons I could configure to the shoot button.



  • if you set zapper mode to "lightgun", you need to bind the mouse buttons first for it to work (settings > input > user 1 binds)

    if mouse does not move, try changing zapper mode to mouse or touch. i dont know whats the default input driver for pie, but at least one of them should work if lightgun does not.

    if the crosshair did not appear after loading the game, it means auto-controller detection has failed. set Zapper to Player 2 port for normal NES games, set Zapper on Player 1 if its a VS-Unisystem game or zapper wont work and you hear loud alarm



  • if what retrowertz suggested doesn't solve your problem try to set mouse index to '0' for every user binds



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.