Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Start button not working once moonlight is launched



  • Pi Model or other hardware: Raspberry Pi 3 B+
    Power Supply used: Native Pi Power Supply
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.5.1
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: 2 gamepads
    Controller used: ShanWan PC PS3 Controller, Logitech Wireless F710
    Error messages received: None
    Log found in /dev/shm/runcommand.log (if relevant): Not exactly relevant
    Guide used: (Mention if you followed a guide)
    File: (File with issue - with FULL path)
    Emulator: moonlight
    Attachment of config files: https://pastebin.com/6SprEXS1
    How to replicate the problem:

    Pretty much it's there.
    I had a custom RetroPie installation which was working exceptionally fine with my own startup modifications - none related to controllers (mounting of remote filesystems for roms, keepalive on local network etc..) but i wanted to perform raspberry pi reinstall, so I've used RetroPi pre-made image since i want to use retropie only/kodi/steamlink/moonlight only.

    So I've dd-ed retropie image onto SD Card, configured everything but now comes the catch.
    When i Launch Mortal Kombat 10 from moonlight, it will run fine, i can play with ease but i noticed START button IS NOT working in Mortal Kombat (it will not open MK10 menu). I need start button since when moonlight wouldn't quit and if it would leave the stream running in background, i would need to quit using BACK+START+LB+RB but since START is not recognized when pressed, i cannot do that.
    Start is working fine in emulationstation and Kodi. But not when i launch moonlight and mortal kombat 10. I've yet to determine if this is only MK10 related and if Gamepad related (for now I've only tested with Logitech) but the same controller setup worked fine on previous install, before I've removed all and reinstalled using RetroPie image.

    EDIT:
    Ok, so I've tested with other gamepad, start button works fine with it as well as combination "START+BACK+LB+RB" to quit moonlight stream. So i still cannot figure out why Start button doesn't work on Logitech when inside moonlight stream.... Start works fine inside emulationstation main menu as well as in kodi.

    Any help and idea?



  • Got it resolved by editing /etc/modprobe.d/xpad.conf and changing triggers_to_buttons to 0



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.