Please do not post a support request without first reading and following the advice in

Sound error in retropie

  • Hi guys, okay so I'm getting an error every time I start a game, exit a game or go to any other menu than emulation station.

    The error is:
    lv10: VolumeControl ::init() failed to find mixer elements

    I use a raspberry pi 3 model B

    I've looked here

    And here

    And these does not help.

    To be clear. I have sound in games, snaps and splash screens. But the error comes before game starts/exits etc.

    Please help. I've built the most amazing arcade machine and that error drives me nut s

  • Global Moderator

    That's a harmless warning - it can be corrected by changing the Audio device in the Sound options of Emulationstation. Try changing it to PCM, then restart Emulationstation.

  • @mitu it already says that, but something else might need to be corrected. This is a screenshot of the a play -L command

  • Global Moderator

    @RpiBeginner No, using those options is the way to get rid of that warning.

  • @mitu okay, but how do you explain that I still get the warning? Mine says PCM already

  • Global Moderator

    @RpiBeginner If PCM still yields a warning, try another option or another Audio device. How did you configure your sound - is it over HDMI or through the analog jack ?

  • @mitu It's a USB soundcard, and ends in a 3.5 mm jack. Its always easy to suggest "Use another sound card".. Just the worst solution

  • Global Moderator

    @RpiBeginner said in Sound error in retropie:

    Its always easy to suggest "Use another sound card"..

    I was suggesting to change the settings in Emulationstation, not the device...

  • @RpiBeginner just wanted to point out that your screenshot is 'aplay -l', and the instructions say 'aplay -L'. You need the capital L option to get the right output. That will allow you the correct name of the audio card.

    Each audio card has one or more audio mixers (audio devices) on the audio card. Emulationstation needs to know which audio mixer to use on the audio card when you do the volume up and down. To find that out you need to use 'amixer scontrols -D <AudioCard>', where <AudioCard> is replaced by the name of your audio card you got in the previous step. I know from your screenshot that your audio card is set to the 'default', so you should run 'amixer scontrols -D default'. That command should show you the correct name of the audio mixer on your 'default' audio card. It will most likely be called 'Digital' or something like that. Please note that you must copy the name exactly as it is printed.

    Those two commands above will give you the settings you need.

    The first command gives you the name of the audio card you select in emulationstation, which is 'default' (based on your screenshot).

    The second is the name of the audio mixer (audio device) on that audio card, which you'll need to run yourself to get.

    That would be all you need to get around for most things... Except video sounds. RPI uses OMX player to play the sounds from video files, and they need a third setting! This setting looks different again from the ones we got earlier. The format is:


    That setting will use the first mixer on the first audio card for video sounds. If that setting doesn't work then you should try 'hdmi:hw:0,1', which will use the second mixer on the first audio card.

    Hopefully that will give you all the information you need right there. Remember that if you cannot select the setting directly from within emulationstation you can add the setting directly to the es_settings.cfg itself . Please see the instructions page I linked to earlier for more details if you need to do that.

    Hope this all helps! Good luck.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.