Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Where is my Hotkey Issue?



  • For some reason, my custom hotkeys are not enabled. I have copied my RPi 3B+ 4.1 build controller configs over to my fkms RPi4 build. All core packages updated to source. Select + Start to exit and select + Y work to go to the RA menu, but custom hotkeys such as fast forward toggle, fast forward hold, and rewind no longer work for me.

    ./configs/all/Retroarch.cfg: https://pastebin.com/ePTC6JBy
    ./configs/retroarch/autoconfig/Microsoft X-Box 360 pad.cfg: https://pastebin.com/CUCv6K4x
    ./configs/retroarch/autoconfig/Sony Computer Entertainment Wireless Controller.cfg: https://pastebin.com/AD1hu52v


  • Global Moderator

    From a cursory look at your config files

    • Rewind seems to be disabled via the main config file (rewind_enable = "false"). You should enable it first.
    • On a default RetroArch install, I see there's a input_rewind_btn, try setting it on your desired button input code.
    • same for input_hold_fast_forward_btn and input_toggle_fast_forward_btn.


  • @mitu Ah. Good point. I have it enabled specifically by system.

    NES Example: https://pastebin.com/xy93n4nA

    Is this bit of code causing a problem?: #include "/opt/retropie/configs/all/retroarch.cfg"

    Suppose that may need uncommented? Would it behoove me to change it to /home/pi/RetroPie//configs/all/retroarch.cfg?


  • Global Moderator

    @hooperre said in Where is my Hotkey Issue?:

    Ah. Good point. I have it enabled specifically by system.

    I see, in this case it doesn't need to be enabled also in the all config folder.



  • @mitu said in Where is my Hotkey Issue?:

    From a cursory look at your config files

    Rewind seems to be disabled via the main config file (rewind_enable = "false"). You should enable it first.

    On a default RetroArch install, I see there's a input_rewind_btn, try setting it on your desired button input code.

    same for input_hold_fast_forward_btn and input_toggle_fast_forward_btn.

    Thanks, man. That fixed it.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.