Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Can not get EmulationStation to fit on CRT composite screen



  • Official RetroPIE image 4.4
    Raspberry PI 3
    Emulatonstation version 2.8.4RP
    Okay so here is my problem..bottom line I have tried nearly everything to make ES fit on my screen. I have an old card with raspian jessie on it and everything fits PERFECT. I am having a problem on stretch (I guess?)

    Okay long story follows:

    I tired to turn off the overscan using the raspi-confg I get:
    ] message... on boot

    I tried to turn on the overscan using the raspi-config I get:
    ok ] message..on boot

    so from there I know I need it on because I can see more of my screen
    (on boot you should see [ ok ] message)

    now I can set the terminal screen size using the config.txt and have a PERFECT fitting terminal but after loading ES the screen is too large (all edges of ES are cut off) and retroarch for that matter and the screensaver (but the preview snaps fit perfectly.

    here is a snippit of my config.txt the SAME config.txt (well same settings anyway) I have used on three other cards all work fine (one loads Mate desktop, one loads Kodi, one loads ES perfectly, (but it is jessie based)).

    uncomment the following to adjust overscan. Use positive numbers if console
    goes off screen, and negative if there is too much border
    overscan_left=14
    overscan_right=15
    overscan_top=-4
    overscan_bottom=-2

    uncomment to force a console size. By default it will be display's size minus overscan.
    framebuffer_width=720
    framebuffer_height=480

    uncomment for composite PAL
    sdtv_mode=0
    sdtv_aspect=1

    Now to make it fit and look great I add "overscan_scale=1" to the config.txt and ES fits almost perfectly! The left edge of ES is cut off (You can not see the button picture for the options on the help at the bottom of the screen or the first letter of the game on the list using the carbon theme). Now the video snaps have a black border around them in the preview window and the video screen saver as well...

    for fox sake give me some ideas on how to fix this..I have almost lost my sanity!

    EDIT: I got ES and retroarch to fit perfectly now...but the screensaver and preview windows still have a black border around them...can I edit something in the theme settings?
    and if I can how do I do that (what do I need to change)?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.