Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

No lr-* emulators run



  • Setup info:
    Pi Model or other hardware: Raspberry Pi 4 Model B (I know, unsupported)
    Power Supply used: 15W USB C Charger (Pixel Charger)
    RetroPie Version Used: 4.5.1
    Built From: Source via Retropie-Setup fkms_rpi4 branch
    USB Devices connected: Microsoft Wireless Receiver, Logitech Wireless Mouse/Keyboard combo
    Controller used: 8Bitdo SF30
    Error messages received: failed to add service - already in use?
    Guide used: https://retropie.org.uk/forum/post/200661
    Emulator: lr-mgba, lr-fceumm, lr-snes9x, lr-gambatte (and others named lr-*)
    How to replicate the problem: From fresh install of Retropie, just attempt to launch any or Retroarch menu from settings.

    Extras in config.txt: (same result on fresh Raspbian SD without modifications, following is current)
    gpu_mem=512 (tested 64, 128, 192, and 256)
    over_voltage=6
    arm_freq=2147
    gpu_freq=750

    The only emulators that actually work are ppsspp and mupen64plus (since they're not retroarch emus). I'm assuming it has to do with the video driver. At the bottom when trying to launch with verbose logging:

    [INFO] [Audio]: Set audio input rate to: 47872.40 Hz.
    [INFO] [Video]: Video @ fullscreen
    [INFO] [Video]: Starting threaded video driver ...

    failed to add service - already in use?
    

    I've tried updating everything, removing, reinstalling, doing a basic install over a current install, building each emulator individually, building retroarch individually. All with the same result. I had no problems originally when I first setup the system (about October 5th) except Mupen64Plus did not work. After a few days, I did an update via Retropie-Setup, and behold, Mupen64plus begins working fine.... Now none of my other emulators work.



  • @Skreelink I've never had that problem so I'm not sure.
    Did you enable the GL (fkms) driver in raspbian?



  • @Darksavior said in No lr-* emulators run:

    @Skreelink I've never had that problem so I'm not sure.
    Did you enable the GL (fkms) driver in raspbian?

    Yes, LXDE doesn't even come up unless the fkms driver is active. From what I've read, it's default now and the legacy driver is no longer an option.



  • @Skreelink said in No lr-* emulators run:

    LXDE

    I'm using raspbian lite. Never used the desktop environments.



  • @Darksavior said in No lr-* emulators run:

    @Skreelink said in No lr-* emulators run:

    LXDE

    I'm using raspbian lite. Never used the desktop environments.

    Usually when I run emulation station, I'll hit ctrl-alt-F1 to move to tty1 and do "sudo service lightdm stop" to kill the desktop environ before running emulationstation.

    Edit: Ugh, one of the worst parts is having to compile the entire thing since they don't have binaries yet. Trying a clean lite SD card now.



  • Same thing happened to me. Same set up. Rpi4 4gb, Raspbian lite. Latest RP-Setup fkms branch (last updated 10-11 days ago).

    Flycast worked right away, but then I ran updates and updated firmware and issue returned. I'll rebuild tonight and test every step of the way see what exact step is causing the issue. This Pi is in an arcade build, so the only cores I'll test are mame2003, fba, and flycast. All are lr- builds, so I should know right away if/when the issue happens.


  • Global Moderator

    @hartleyshc This is because retroarch has not been yet ported fully to the Pi4 and because you used rpi-update, which messes things up w.r.t. the GL libs.
    As a quick fix, remove /opt/vc/lib/pkgconfig/egl.pc and rebuild the retroarch package. Don't use rpi-update in your regular update process, it's not meant for that.



  • @mitu , thanks for the help.

    Tried that solution, did not work. Probably it is better to wait for a stable port to rpi4.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.