Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Connection issues with bluetooth gamepad



  • Hello everyone!

    I'm running the latest version of retropie using a rpi4.

    I have two generic bluetooth gamepads (the T3) and I'm experiencing some connection issues with them.

    I was able to pair the gamepad and it works, but, and this may sound weird, as I use them the signal seems to weaken and it starts missing button strokes. If I turn it off and back again, the issue disappears and eventually reappears as I use it again.

    I'm 3-4 meters away from the pi.
    I have tried both gamepads and the issue is the same.
    I've tried a bluetooth usb adapter (iogear 521 which seems to be a good adapter) and the issue is the same.
    I've tried the gamepads in a laptop and they work fine under the same distance.

    I think this is a software or configuration issue. Any ideas on how to start debugging this?

    Thanks!


  • Global Moderator

    @parra said in Connection issues with bluetooth gamepad:

    I've tried a bluetooth usb adapter (iogear 521 which seems to be a good adapter) and the issue is the same.

    Did you disable the onboard BT after adding the adapter ? The connection could still be using the on-board BT chip.



  • @mitu yes I did! thanks


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.