Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Cannot update or re-install retroarch on 4.6 buster image on a Pi4



  • Tried to re-install retroarch, since I was getting an error when trying to retrieve cores from its interface (it would say that the core list can't be found, and yet, games run fine).

    Although, I get a git error. I tried both installing the binary, and from source. Not sure if this is something expected or not, but it is the first time I can't update cores from within the retroarch interface, and that I get an error for even trying to re-install or update retroarch from within the retropie script.

    Is this a known issue? Do I have to do something special on my Pi4 to get this sorted out? Thanks


  • Global Moderator

    @raspnoobie said in Cannot update or re-install retroarch on 4.6 buster image on a Pi4:

    Tried to re-install retroarch, since I was getting an error when trying to retrieve cores from its interface (it would say that the core list can't be found, and yet, games run fine).

    this is now how to install cores in retropie. see https://github.com/RetroPie/RetroPie-Setup/wiki/Updating-RetroPie#updatinginstalling-individual-packages

    and that I get an error for even trying to re-install or update retroarch from within the retropie script.

    what's the error?



  • I get error from GIT; it start cloning and then give me "error running git pull returned 1"

    I tried to run the update option too, and the result is that it start retrieving and compiling deps, drivers and such, but then it get stuck in the same way. Since the console get erased, I have no chance to grab a snap of what was the component that cause the git error. This is what I was able to get so far, before it start to compile deps submodules:

    = = = = = = = = = = = = = = = = = = = = =
    Getting sources for 'retroarch' : RetroArch - frontend to the libretro emulator cores - required by all lr-* emulators
    = = = = = = = = = = = = = = = = = = = = =
    
    HEAD is now at 36802f7 Update CHANGES.md
    M       configuration.c
    M       configuration.h
    M       menu/menu_driver.c
    M       retroarch.c
    Already up to date.
    HEAD is now in branch 'HEAD' at commit '36802f713312dc16c93a7765cd4a1b0883db5a61'
    /home/pi
    /home/pi/RetroPie-Setup/tmp/build/retroarch /home/pi
    
    = = = = = = = = = = = = = = = = = = = = =
    Building 'retroarch' : RetroArch - frontend to the libretro emulator cores - required by all lr-* emulators
    = = = = = = = = = = = = = = = = = = = = =
    
    Checking operating system ... Linux
    Checking for suitable working C compiler ...
    
    
    

    After that there is a ton of build data, until the process bail out and I get that error 1 from git pull.

    as far as cores updates, I have to download them from within the retropie script and not anymore from retroarch itself, thanks for the clarification. That would explain why retroarch is not able to find cores.


  • Global Moderator

    @raspnoobie said in Cannot update or re-install retroarch on 4.6 buster image on a Pi4:
    build logs are available in /home/pi/RetroPie-Setup/logs
    can you upload an example one please?



  • Good call on the log; I didn't realize that the update was logged.

    It fail right after copying the default configuration

    xmb/monochrome/png/NEC - PC-FX.png
    xmb/monochrome/png/ScummVM-content.png
    xmb/monochrome/png/Commodore - Amiga.png
    xmb/monochrome/png/battery-full.png
    xmb/monochrome/png/NEC - PC Engine CD - TurboGrafx-CD-content.png
    xmb/monochrome/png/menu_latency.png
    xmb/monochrome/png/Sinclair - ZX 81.png
    xmb/monochrome/png/input_MOUSE.png
    xmb/monochrome/png/core-options.png
    Copying new default configuration to /opt/retropie/configs/all/retroarch.cfg.rp-dist
    /home/pi
    Error running 'git pull' - returned 1
    
    Log ended at: Sun 24 May 2020 12:43:24 PM PDT
    Total running time: 0 hours, 5 mins, 18 secs
    

  • Global Moderator

    please upload the full log


  • Global Moderator

    one thing you can try is removing this folder:

    /opt/retropie/configs/all/retroarch/shaders

    and trying again.



  • Trying now without that folder. BTW how do you upload files? I don't see an option for files, just for links and images.


  • Global Moderator

    @raspnoobie thanks! you can try https://pastebin.com/



  • You nailed it; once I deleted the shaders folder from retroarch, the update went through without issues.
    Thanks!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.