Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Rpi 4, No display on my 3440x1440 monitor, works perfectly on my 4k TV.


  • My monitor is the MSI Optix MAG341CQ. My Raspberry Pi 3B+ works perfectly with the monitor, but the Rpi 4B 2gb won't show signal on the monitor.
    Also, whenever I try to set "Custom Resolution" I'm instantly sent back to the previous raspi-config screen(obviously while using my 4k TV).
    Worth noting. The monitor is 100hz. I've tried turning freesync off, I've tried playing with the aspect ratio settings of the monitor. And tried disabling/enabling basically all features. Also, when I am using my PC on the monitor and plug in the Rpi4 the screen automatically switches to the HDMI input, but stays blank momentarily and switches back to my PC Displayport input. With the PC powered off, the same thing happens, except after being blank momentarily a "No Signal" message pops up.

    Pi Model or other hardware: 4B 2GB
    Power Supply used: Vilros 5.1v 3.0A
    RetroPie Version Used: 4.6.1
    Built From: RetroPie website default image.
    USB Devices connected: Logitech keyboard
    Controller used: Dualshock 4
    Error messages received: None, just blank screen.
    Log found in /dev/shm/runcommand.log (if relevant): N/A
    Guide used: N/A
    File: N/A
    Emulator: N/A
    Attachment of config files:N/A
    How to replicate the problem: Have a 3440x1440 monitor and simply try to plug your Raspberry Pi 4B into it via HDMI.

  • Global Moderator

    Try adding to the config.txt file on the sdcard:

    hdmi_group=1
    hdmi_mode=16
    

    this should set-up 1080p for the display.


  • @mitu I tried this and it didn't work. I then found a website with as list of all sorts of different video resolution settings and none of them worked. https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

    What is odd is that if I start the RPi in 1080p mode with the monitor plugged in, then after the screen stays blank, I plug it into the 4K TV, the signal still stays blank. But if I start it with the 4k TV plugged unplug it and then replug it back into the 4k TV there is still signal. If I start it with the 4k TV, get signal, then plug it into the monitor the screen stays blank.
    I also tried placing my monitor into 1080p mode via Nvidia Control panel on my PC, and it displays 1080p 60hz on my PC despite the stretched distortion. I just wanted to make sure my monitor could display the resolution.
    I then tried using an HDMI to DisplayPort converter to test if it was an issue with the HDMI port. I have tried two different HDMI cables that I know work.
    Enabling "HDMI_Safe=1" didn't work either.


  • Okay, I found a "workaround".

    I used an "HDMI to DVI-D converter".
    hdmi_ignore_edid=0xa5000080
    disable_overscan=1
    hdmi_group=2
    hdmi_mode=73

    It looks pretty good, but it requires extra hardware. Fortunately I hoard cables and converters and such, and fortunately the monitor has that DVI-D port. Hopefully in a future update HDMI support for this monitor(resolution?aspect ratio?) for the Rpi4 will be added.

  • Global Moderator

    @MegaTimX said in Rpi 4, No display on my 3440x1440 monitor, works perfectly on my 4k TV.:

    Hopefully in a future update HDMI support for this monitor(resolution?aspect ratio?) for the Rpi4 will be added.

    Unless someone reports it upstream, I don't think it will be magincally solved.
    Someone reported something similar this last year and for them it has been solved with a firmware update, see https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=248037&start=25.

    If the recommendations in that topic won't solve your issue, then I suggest replying to that topic and adding your own monitor EDID for the RPT engineers to check it.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.