Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Raspberry Pi 4 main screen fall back to secondary screen?



  • Is there a way to setup my Pi so thatit would default to HDMI 2, but if HDMI 2 is not connected, fallback to HDMI 1?


  • Global Moderator

    It shouldn't need any configuration, as long as the correct HDMI port is connected at boot. Though this is not really 'dual screen', as you topic title suggests.



  • No, I mean can I set a main screen which falls back to a secondary screen if it is not detected


  • Global Moderator

    No, I mean can I set a main screen which falls back to a secondary

    I just said you don't need a configuration for that. Did you test it and it doesn't work ?



  • HDMI 1 is main screen right? Sorry to waste your time with my noob-like quesitons, just never used a Pi 4 before...


  • Global Moderator

    The Pi will initialize the HDMI port which is connected. If you only have 1 HDMI cable, it doesn't matter which port it's plugged it.
    It's only when you have both ports connected, that the 1st port is going to be used as the primary/main display.



  • Ok, I know this may be a bit annoying but...

    To be 100% sure, if I launch emulationstaton on a rpi 4 these will be true:

    HDMI 1 HDMI 2 Result
    Connected. Connected. HDMI 2 only
    Disconnected. Connected. HDMI 2 only
    Connected. Disconnected HDMI 1 only



  • I think the HDMI ports are 0 and 1. Port 0 is closer to the USB C power connector or outside edge.

    I am running 4.6 on a Pi 4 (not sure on the exact build--a few weeks old) I had a weird issue where I had no audio (video was perfect) on a LG TV using HDMI 1.

    After reading on the raspberry pi forums I tried a few suggested commands like hdmi_force_hotplug=1, hdmi_drive=2 and hdmi_force_edid_audio=1. After adding those to the /boot/config.txt and rebooting I could no longer get video on HDMI 1.

    So I moved the HDMI cable from 1 to 0. The resolution was set very low like some default resolution. It was enough to work through the screens and restart vs slamming it.

    With or without those commands in the config.txt HDMI 0 works fine with video/audio. HDMI 1 only works when they are not present but then I have no audio.

    It's not a big deal by no means but I definitely don't have the flexibility of using either port on my TV. I'll have to try another TV and see if I get the same results.



  • I started with a fresh image and upgraded to 4.6.1 commit 63f4f55f. I configured the keyboard, enabled SSH and copied one game over.

    I tried several TV's (LG, Samsumg, Sharp, some Best Buy house brands) all with the same result. HDMI 0 works perfectly and HDMI 1 has no audio. When I force audio on HDMI 1 I see the boot screen text for a moment and right before it's going to display the RetroPie logo it goes black.

    Long story short I think the Argon One daughter board is causing some type of issue with RetroPie when using HDMI 1.

    Anyway HDMI 0 works perfectly but it's something to note possibly if having issues.



  • @Riverstorm Would it work without the daughter board?



  • @Bluebotlabs said in Raspberry Pi 4 main screen fall back to secondary screen?:

    @Riverstorm Dould it work without the daighter board?

    Sorry, it was late and I didn't want to tear the case apart, clean it up and redo the thermal paste/tape (I can't remember what I used as it was months ago) and since HDMI 0 is working fine I figure I'd leave good enough alone. It sounds like no one else is having an issue and can initialize on either port so I figure the Argon board is suspect.

    I need to buy more thermal tape to have on hand but any international shipping seems to be delayed for weeks. I bought some items back in March out of Poland and I'm still waiting. I contacted the vendor and all he added was it's probably caught up in customs sitting in some warehouse.

    Anyway every TV I tried it on with a fresh 4.6 image was exactly the same. When I do tear it open I'll do a more definitive test.



  • @Riverstorm Sorry, didn't realise you would have to tear apart your build, I'll run some experiments myself once I have the parts



  • @Bluebotlabs - Yeah once I crack a case open I throw the tape away or spend time with alcohol and swabs cleaning the chips and case of paste and apply new.

    If I remember there are two heat sync stand-off's that make contact. The finish on one of the screw stand-off's caused an issue also. The Pi wouldn't sit flush. It was less than a mm so not a big deal at all to correct. The case comes with tape but occasionally I'll sand off the finish on stand-off's and use thermal paste for better thermal transfer to see if I can get the temps down a bit more.

    With a new case it would be ideal as you could just hold the case together and test it with no tape/paste or screws.



  • @Riverstorm I don't think it's the argon one case causing the issue. Afaik HDMI 1 doesn't natively carry an audio signal. I once found a command to force audio through HDMI 1 but the results were not good.



  • @quicksilver - Hey there, nice, that would solve the issue we've been discussing if that's the case...no pun intended! :) So you can't use HDMI 1 on a Pi 4 with RetroPie without forcing the audio?

    When I try and force the audio on HDMI 1 with these commands hdmi_force_hotplug=1, hdmi_drive=2 and hdmi_force_edid_audio=1 I loose the video also. Basically a black screen.

    Those commands work fine on HDMI 0 and also there's no issues with those commands on a Pi 3. With certain TV's that don't seem to "negotiate" the HDMI signal properly they work wonders when it came to audio issues with a Pi 3 to just force it.



  • @Riverstorm said in Raspberry Pi 4 main screen fall back to secondary screen?:

    So you can't use HDMI 1 on a Pi 4 with RetroPie without forcing the audio?

    As far as I know, that is correct. I remember this being an issue when the pi 4 first came out and the answer at that time was to use the HDMI 0 port and the HDMI 1 port was just intended to be a 2nd display in a dual display setup.


  • Global Moderator

    @quicksilver 2nd HDMI port audio works fine, it was just the default configuration - before the recent changes to the on-board audio - that was not enabling audio on it.



  • @mitu ah gotcha, thanks for setting me straight



  • @mitu - Sorry guys, I'm playing catch up here. If you update the RetroPie script and are running ES 2.9.2 you just need to select your output device via the ES audio menu for the 2nd port?


  • Global Moderator

    @Riverstorm No, just select HDMI and that's all. If you have any issues, post in the stickied topic.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.