Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Dragonrise Arcade Joystick not registering on Mame 2003-Plus



  • I recently bought one of those generic Dragonrise joystick kits from Amazon. I had no problems putting it in a case and hooking it all up. It works fine in seemingly every other emulator but Mame 2003-Plus. That's the only emulator Galaga seems to run on, which was my intention to play. The buttons seem to register just fine and I can fire away, but the joystick does nothing. I've tried registering it in Mame, but it doesn't work. I've tried making sure the settings in Retroarch are correct and as far as I can tell they are.

    Can anyone point me in the right direction?

    This is on a Pi 4 with the latest RetroPie.



  • Open the options on the Retroarch menu and there's an option whose label I forget that will "map directions to digital" instead of analog. It's set to analog by default. I had to do it a few days ago.

    See if it works.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.