Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Using the Raspberry Pi 4B 4GB, I power on the pi and get no output to my tv or monitor through my HDMI to micro HDMI cable (I assumed the cable was the issue at first and got a replacement). I can SSH into and see the RetroPie banner in the shell. I have tried changing nearly every value in /boot/config.txt to force HDMI to no avail (even hdmi_safe didn't work).

    Is there anything else I can try? My next assumption would be that the hdmi ports on the pi are shot.

    Pi Model or other hardware: 4B
    Power Supply used: Canakit Pi Power Supply
    RetroPie Version Used: 4.6
    Built From: pre-made image on SD card
    USB Devices connected: none
    Controller used: none
    Error messages received: none
    Verbose log (if relevant): none
    Guide used: none
    File: none
    Emulator: none

    CONFIG FILE: /boot/config.txt

    # uncomment if you get no picture on HDMI for a default "safe" mode
    #hdmi_safe=1
    
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    #disable_overscan=1
    
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    #framebuffer_width=1280
    #framebuffer_height=720
    
    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    hdmi_ignore_edid=0xa5000080
    hdmi_force_mode=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=1
    hdmi_mode=19
    
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    #hdmi_drive=2
    
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    #config_hdmi_boost=9
    
    # uncomment for composite PAL
    #sdtv_mode=2
    
    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800
    
    # Uncomment some or all of these to enable the optional hardware interfaces
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    
    # Uncomment this to enable infrared communication.
    #dtoverlay=gpio-ir,gpio_pin=17
    #dtoverlay=gpio-ir-tx,gpio_pin=18
    
  • Global Moderator

    Do you get the boot 'rainbow' and the 4 raspberries on start-up ?

    To check for any issues with the Pi detecting the proper resolution, you usually can add hdmi_safe=1 to the config.txtfile and see if you get an image. Your config.txt is missing the Pi4 specific overlay for the GPU drivers, which is present on the default config.txt file - you should put that back.
    What display are you using (monitor/TV/model) ?


  • Try editing /boot/config.txt with ignore_lcd=1
    Then reboot. Your RPI should know show over HDMI instead of lcd

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.