Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Dpad stops working when analog to digital type is set



  • I am using a raspberry 3 model a+ with the 4.6 retropie image, I flashed it using etcher. I want to use the analog stick and the dpad at the same time for some games. For example on lr-stella (atari 2600), I have "Analog to Digital Type" set to left analog. This makes the analog stick work, but the dpad stops working. When I set it to "None", the dpad works again. How can I make it so both work? It also would help if anyone knows how I can debug it myself


  • Global Moderator

    @analogstick Does it happen for all emulators ? I can't reproduce this with lr-stella2014 or lr-fceumm. What controller are you using ?



  • @mitu Yes it happens for all emulators. I am using a custom controller. It's actually a Gameboy zero using a custom PCB. I was able to map the inputs just fine.


  • Global Moderator

    @analogstick As said, can't reproduce. Update your RetroPie-Setup and packages and re-try, maybe there's a RetroArch change that affects your setup.



  • Had a similar issue with my kidzplay racingwheel.
    For that i just mapped the analog control as D-pad without using the "Analog to Digital" option for the individual games i used it with.

    Since your controller is broader, you can save the button mapping for entire systems, that do not use analog buttons at all.
    Only the systems that do use it you'd still have to do it per game for.

    Not really a solution, but its a workable workaround.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.