Please do not post a support request without first reading and following the advice in

  • Hey everyone - I'm setting up a vertical bartop running on a Pi Zero. I've got everything running smooth and vertical EXCEPT for PiFba. I've modified fba2x.cfg to set up the controls and it works perfectly. However, no matter what I do, it will not rotate the display. I've tried setting the "DisplayAutoRotate" parameter to every number known to man and it simply has no effect.

    The graphics portion of my config is as follows:
    Display Effect: 0 none, 1 scanlines

    Is there something I'm missing here?
    (And I know, the obvious solution is to use lr-2000 mame, but for some titles the performance just isn't there.)

    Thanks everyone!

  • Global Moderator

    1 should mean that vertical games rotate, and 0 should mean they stop rotating, i believe.

    can you give an example of a game that's not working as above? and the corresponding output after running in /dev/shm/runcommand.log?

  • @dankcushions I think you may have uncovered my problem here - does this option ony work on vertical games? I am trying to get ALL titles to run on a vertically oriented monitor. Once I get home I'll try running a title and checking the runcommand log.

  • Global Moderator

    @eddygenotype ya, if you're wanting ALL games to be rotated you need to use retroarch cores, or rotate via /boot/config.txt setting display_rotate=1 (possible performance issues)

  • @dankcushions arrrrgh. Thanks. Definite performance issues when rotating the whole system, and PiFBA is the only core that's giving me issues otherwise. Now I'm off to see if I can compile FBNeo with Cyclone and see how that runs. Thanks for your help!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.