Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hi All,

    If anyone can help me on this I would be extremely grateful.

    I had Retropie working great on my Pi 3 model B, with 2 clone PS3 controllers (P3) working perfectly.
    I then went into the retropie setup and did a full update, updating the setup script and all packages.
    Now my PS3 controllers don't work. i've tried uninstalling and reinstalling the PS3 driver on all using all the different configurations but no joy.

    One thing I noticed is that previously I would install the package, then go into config and all options would say Install... Now when I install the package the top option for genuine PS3 controllers says Pair and the others say Install. Don't know if this has anything to do with it though.

    Before updating, I just installed the PS3 driver package, installed the Gasia only model and plugged the controllers in.
    Hey presto, they connected to built in bluetooth perfectly.

    I stupidly did not take a backup before doing the update. I could reinstall retropie and set everything up again, but I was hoping to avoid it if possible.

    Like I said, any help would be massively appreciated.

    Paul

  • administrators

    It installs standard ps3 driver by default. Make sure RetroPie-Setup is up to date. Go to manage packages / manage drivers / ps3 controller and choose to install the driver for your clone, then choose pair.


  • @BuZz Hi Buzz, Thanks for your response.

    I have tried this but to no avail. RetroPie-Setup fully up-to-date, choose to install the Gasia only version and pair, plug in the controller for 30 seconds (more than enough), but when I unplug the lights just flash and flash.
    I've tried all the other PS3 driver variants (Gasia Clone Support, Shawan), also to no avail.

    I've done a fresh install on a new card of version 4.0.1, installed the PS3 Driver Package, installed the Gasia Only version, pair and the controllers work perfectly. Same PI 3.

    I know that when I first got the PS3 controllers, I had some trouble setting up. I couldn't get them to pair, and I'd tried all the options. Then I read online that one guy tried all the options, but chose to Remove PS3 Controller Configurations between each option. I did this and Gasia Only option worked perfectly. This has led me to be suspicious that the PS3 Driver only works for my Generic P3 (The say P3 instead of the PS3 Logo) Clone controllers.

    For now, I think I will resign myself to setting up a fresh copy of 4.0.1. This issue will still be there when I do finally update though.
    Not really sure where to go from here. Any thoughts?

    Again, thanks for the response.

  • administrators

    How do you mean a fresh 4.0.1? 4.0.1 was never released as a standalone image etc.


  • @BuZz Ah, my bad. I installed not directly from the image but from a backup I took a couple of weeks ago. I'd obviously already updated to 4.0.1 at that point. Sorry for the confusion.
    I could reinstall straight from the latest image for download on a new card and test the controllers on that if that info would be helpful?

  • administrators

    @vbaguru on current updated image, did you try rebooting after installing gasia only, and then doing pair?

  • administrators

    @BuZz latest image doesn't include the recent fixes I made for the ps3 package, which others have confirmed that it fixes their issues. But looks like it's problematic on your setup perhaps, so I need help to debug it.


  • @BuZz I'm more than happy to help. Should I start by doing a fresh install of the latest image, then running a full update so that I'm on the version 4.0.2 with the fixes you've made to PS3 package?
    Then I can install the Gasia Only, reboot, then pair and see if it works?

  • administrators

    @vbaguru yes please. Update before installing the ps3 driver


  • @BuZz just to be clear, I should update everything before proceeding, yes? (RetroPie-Setup, Installed Packages, Underlying OS and Kernel)

  • administrators

    @vbaguru just updating the retropie-setup script is enough to test this


  • @BuZz OK, I've tested both just updating the RetroPie-Setup and updating everything, and both work perfectly. Install Gasia Only, Restart, Pair controller, all works fine.
    I'm now going to test the image I'm having a problem with. If that persists, looks like it's just something to do with that setup and I can just start a fresh one.


  • @BuZz have to pop out for an hour, I'll test my problem setup when I get back but looks like it is something I may have done wrong rather than something wrong with the package. Thanks for your help on this, sorry to have wasted your time.

  • administrators

    no probs! glad it's working on the new install at least.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.