Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Jetpac on ZX Spectrum



  • Thanks for the replies! I have got Jetpac running now, however my controller doesn't work in it. I am using XBOX 360 wireless controller and I set it up as Kempston joystick which works fine in other games such as Manic Miner. I can get to an options screen by pressing the B button which has an option for selecting Joysticks which I set to Kempston but it didn't help.



  • @Yorick How did you set up your controller as Kempston?

    The default joystick emulated in lr-fuse is Cursor. You can play Manic Miner with the arrow keys which explains why your controller works here.

    To change the default to Kempston, you can either change the joystick emulated in RGUI or, for a permanent solution, you can edit /opt/tetropie/configs/all/zxspectrum/retroarch.cfg as described in my previous post.



  • @dudleydes I changed the line in /opt/retropie/configs/all/zxspectrum/retroarch.cfg to input_libretro_device_p1 = "513" like you suggested.

    Then in the Jetpac game there is an option menu called peripherals with an option to select Kempston where you have to press space bar to select it and then enter to save settings.



  • @Yorick I'm not sure about the peripherals menu you are speaking about.

    This is the menu I see
    https://www.mobygames.com/game/zx-spectrum/jetpac/screenshots/gameShotId,87771/

    If I press SELECT on my controller, then a keyboard overlay appears. I can then use my controller to "press" 4 to select Kempston and 5 to start a game.



  • My Xbox controller doesn't work at that screen so I press 4 on my Keyboard to select Kempston and then 5 to start game. Then the game runs but my controller still doesn't work except for the B button which opens a menu where you can select option-peripherals and activate Kempston by pressing space and enter.



  • @Yorick I cannot see the "option-peripherals" - can you confirm which emulator you are using?



  • lr-fuse and run Rom as 48k



  • @Yorick I'm stumped! All I can suggest is to test with other games.



  • Sorry to dredge up an old topic, but hopefully this is a quick fix.

    I've updated my /opt/retropie/configs/zxspectrum/retroarch.cfg to add

    input_libretro_device_p1 = "513"

    And JETPAC now works fine with Kempston joystick. BUT my other favourite game is Chuckie Egg, which doesn't support Kempston.

    So for that game I need to switch the mapping to Kempston off, and go back to the default cursor joystick (which works fine).

    On the runcommand window there is an option to 'edit custom Retroarch.cfg config for this RoM' but when I type the original contents of retroarch.cfg in there, the joystick still appears to be mapped as a Kempston.

    Is there another code I need to explicitly set to revert back to a cursor joystick just for this one particular game?

    Thanks



  • @gtbfilms I'm pretty sure that in the RGUI you can just save a game specific configuration file that'll do the trick. I think that's how I have mine set up.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.