Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroArch Crashes (?) after update



  • Pi Model:3
    RetroPie Version Used: 4.1.5
    Built From: Pre made SD Image
    USB Devices connected: sinoarcade controller, keyboard
    Controller used:both
    Error messages received: none
    How to replicate the problem:

    Ever since I ran the last update on RetroPie RetroArch seemingly quits every time I select a menu option. I can launch RetroArch from either inside an emulator or within emulation station and access the main menu and info just fine. However selecting any option in RetroArch just kicks me back to the emulator as if I had exited it.



  • Ive tried removing and reinstalling RetroArch from source and have the same problem. Is there somewhere it drops log files that might give some insight?


  • administrators

    enter runcommand menu and launch in verbose mode then check /dev/shm/runcommand.log

    https://github.com/retropie/retropie-setup/wiki/runcommand


  • Global Moderator

    This post is deleted!


  • @BuZz Thanks you so much for taking the time to look at my thread and reply. I ran rom using verbose mode (http://pastebin.com/4VrWdJ7Z). I can't make too much sense of it myself sounds like it may of exited due to blocking but Im not seeing any indication of what that blocking might be.


  • administrators

    @dfsw At first glance I don't see anything obvious in the log.

    Please can you reinstall both lr-mame2003 and retroarch from binary (not source).



  • @BuZz I reinstalled both from Binary this time, restarted the Pi. Still seeing the same issue. As soon as I select anything past the main menu in RetroArch it exits back to EmulationStation as if I quit. Here is the new log file (http://pastebin.com/nE8X9rES).

    Thanks for the continued help, I really appreciate it.


  • administrators

    Please backup then remove /opt/retropie/configs/mame-libretro/retroarch.cfg and /opt/retropie/configs/all/retroarch.cfg and then re-install both emulators again from binary.

    can share the old configs too if you like so I can check (via a pastebin site), but I think you have some bad config in there.


  • administrators

    I can reproduce the error relating to audio driver (I will look into that - last binary may be missing alsa for some reason), but the game loads fine here, which makes me think it's a romset issue. Are you having this issue with other emulators also ?



  • @BuZz I want to clarify all games on all systems run perfectly fine with the Keyboard. It is only when I try to launch RetroArch GUI and access settings to update the input to work with my D_R_M JUYAO Dual Arcade that it crashes. It also crashes outside of any emulator when I access RetroArch from the RetroPie settings menu.

    Old Mame Config File: http://pastebin.com/XwQ5VUKB
    Old All Config File: http://pastebin.com/PWXP1Wrf

    At the bottom of the All Config you can see where I tried to copy in the input from the Emulation Station file where my controller works as expected, however this did not work for the individual emulators.

    Replacing out the config files and reinstalling does fix the crash that I had when accessing any menu item. However RetroArch still doesn't see my USB encoder as input when attempting to bind the controller (emulation station does).


  • administrators

    Looks like you saved the config from inside retroarch. If you are going to use the RGUI to manage the settings, I would do all the configuring in RGUI. Otherwise, I would do it manually, as it's not too easy to manage the config once it has been saved out from retroarch due to the size.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.