Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • @Dj'KillaD said in lr-mame2003 rom specific rotation + aspect issues:

    @KillerQ I'm also trying to rotate the screen via retroarch menu. Is there any way to save the rotation change per game?

    I use rom-specific .cfg files for each game, but there's a quicker way as well.

    When you come across a game that you want portrait, at least for Retroarch-based MAME games, just go into the Retroarch settings while you're in the game, then go to video settings and change rotation and aspect ratio.

    Once that's done, go back to the quick menus and his SAVE GAME SETTINGS. Those particular settings will be saved for that game.


  • Sorry for resurrecting this thread, but I have a problem I can't seem to figure out. I have the 7" touchscreen and case that requires me to rotate the screen 180 degrees so it's not upside down. I edited boot/cmdline.cfg to do this. Everything works as it should except for vertical games. I have enabled tate mode and my arcade vertical games look like this:

    http://s112.photobucket.com/user/carnage9270/media/20170223_143404.jpg.html

    Any help would be greatly appreciated!


  • @Carnage9270 I can tell you that I have always used a display rotated 180 using my boot/config.txt not cmdline.cfg.

    You will need to provide a lot more detail. You added this comment to an old thread, but we have no idea what image you are using, what version of the Pi you have, or even what emulator you are launching. You mentioned tate mode, so we could assume you are running lr-mame2003 but all we can know for sure is you are running 1943.

    You should read this, then share everything about your system and software.

    Then, tell us what does it look like without tate mode?

    Then, tell us what you want it to look like. Do you want it rotated sideways another 90 degrees?

    I would start exploring per-romsettings to find out what works on your system. I would disable the tate mode, see what it looks like, then create a config file next to your ROM called romname.zip.cfg and put this inside:

    allow_video_rotate = "true"
    video_rotation = "3"
    

    Then, try adjusting the rotation value 1-4 and see what you get.

  • Global Moderator

    actually if you're using tate mode in mame2003 you will want video_allow_rotate set to false, and you set it in the mame2003 config, not per-rom. more info: https://github.com/retropie/retropie-setup/wiki/lr-mame2003#tate-mode

    but yes, we need more info :)


  • @dankcushions said in lr-mame2003 rom specific rotation + aspect issues:

    actually if you're using tate mode in mame2003 you will want video_allow_rotate set to false, and you set it in the mame2003 config, not per-rom. more info: https://github.com/retropie/retropie-setup/wiki/lr-mame2003#tate-mode

    but yes, we need more info :)

    Of course. It's one way, or the other way.


  • Forgive the necro on this, but this thread has helped me greatly and I am sure many other folk come through here searching for the same answers and follow the advice here. In light of that, I thought it important to point out that I followed the solution presented here:

    @dankcushions said in lr-mame2003 rom specific rotation + aspect issues:

    my advice is to put per-rom overrides in /opt/retropie/configs/all/retroarch/config/MAME 2003/

    this is the official retroarch-supported way of using rom overrides. there's a few advantages (settings don't migrate to your main config even if save_on_exit is turned on, etc)

    I noticed, though, that the settings broke after some recent update. It seems now that the proper directory structure for this to work has been changed to the following:
    /opt/retropie/configs/all/retroarch/config/mame2003/

    If you opt to use the other method of placing a romname.zip.cfg file in your ROMs directory instead, then it still works.

    So, for future readers of this thread, I hope this helps.


  • I'm having a bitch of a time with changing "tate" basically it goes like this :

    I'm trying to rotate my games for use with a permanent vertical monitor... I was told to use : under /opt/retropie/configs/all/ in the configuration editor. The option I changed :

    mame2003-tate_mode = "enabled"

    While I'm able to change it with WinSCP within the config file from" disabled" to "enabled", when I reset my pi it reverts back to disabled, WHY !? No matter what I do it's not SAVING the changes i'm making while manually adjusting the config file within notepad++

  • Global Moderator

    @Romstar can you do the change within the RGUI itself? hotkey + X, go into 'options'


  • @Thorr69 said in lr-mame2003 rom specific rotation + aspect issues:

    Forgive the necro on this, but this thread has helped me greatly and I am sure many other folk come through here searching for the same answers and follow the advice here. In light of that, I thought it important to point out that I followed the solution presented here:

    @dankcushions said in lr-mame2003 rom specific rotation + aspect issues:

    my advice is to put per-rom overrides in /opt/retropie/configs/all/retroarch/config/MAME 2003/

    this is the official retroarch-supported way of using rom overrides. there's a few advantages (settings don't migrate to your main config even if save_on_exit is turned on, etc)

    I noticed, though, that the settings broke after some recent update. It seems now that the proper directory structure for this to work has been changed to the following:
    /opt/retropie/configs/all/retroarch/config/mame2003/

    If you opt to use the other method of placing a romname.zip.cfg file in your ROMs directory instead, then it still works.

    So, for future readers of this thread, I hope this helps.

    Just to keep this updated, the directory changed again (RPi 4.5). The new directory is:
    /opt/retropie/configs/all/retroarch/config/MAME 2003 (0.78)/


  • @Thorr69 - Just to add to that I think the folder change was to correct a Retroarch Netplay issue and not so much of a core or RetroPie issue/change. If you're using an older version prior to 4.5 like 4.3 or 4.4 it will probably still use the old path unless your update RA then the new path will apply.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.