Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Raspberry Pi Zero Retropie no HDMI on Samsung TV



  • Pi Model: Zero
    RetroPie Version Used: Linux 4.4.26+ armv6l

    pi@retropie:~ $ tvservice -s
    state 0x12000a [HDMI CEA (16) RGB lim 16:9], 1920x1080 @ 60.00Hz, progressive
    pi@retropie:~ $ tvservice -n
    device_name=SAM-SAMSUNG

    disable_overscan=0
    hdmi_force_hotplug=1
    hdmi_group=1
    hdmi_mode=16
    hdmi_drive=2
    config_hdmi_boost=4

    So my RPi will work on all the other TVs in my house and except for the main living room TV, Samsung UN55D8000. I also tried this on a few TVs at work. So far I have found that it works on Asus monitors at work and the Insignia TV at my house. It didn't work on my Samsung TV and the Sharp at the office. Both which are larger than 55. The RPi does see the Samsung TV which I showed in the tvservice -n above. Any help would be appreciated. I've tried just about everything.



  • Hummm Did you use the same hdmi cable on all the TVs?



  • Yes, the HDMI has been tested across multiple sources and TVs. It works. The current work around that I have going is the RPi through the HDMI in on my Xbox and the Xbox to the TV. It is a dumb work around but it is currently working this way. It will have to do till I can do some more research. At this time I am almost positive that it is failing the HDMI handshake. This seems to be a common problem with Samsung TVs. I haven't been able to find anything that works. Most threads just die with no resolution.


  • administrators

    @jnbui79 Did you try increasing hdmi_boost ? eg to 7 ?



  • Yes, it is currently set to 7. still no change.



  • How bout forcing 1080p?

    sudo perl -p -i -e 's/#hdmi_group=1/hdmi_group=1/g' /boot/config.txt
    sudo perl -p -i -e 's/#hdmi_mode=1/hdmi_mode=16/g' /boot/config.txt
    


  • It is this way. As you can see above, I have posted my config.txt



  • Man thats weird....I have a 65 inch samsung downstairs and the pi seems to work fine with no setting changes.
    Tough one.



  • Boost is at 7 atm. The RPi sees the TV, I can see that when I run tvservice -n


  • administrators

    @jnbui79 please post your current entire config.txt (in a code block)



  • #hdmi_safe=1
    disable_overscan=0
    #overscan_left=16
    #overscan_right=16
    #overscan_top=16
    #overscan_bottom=16
    #framebuffer_width=1280
    #framebuffer_height=720
    hdmi_force_hotplug=1
    hdmi_group=1
    hdmi_mode=16
    #hdmi_drive=2
    config_hdmi_boost=7
    #sdtv_mode=2
    #arm_freq=800
    #dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on
    #dtoverlay=lirc-rpi
    dtparam=audio=on
    gpu_mem_256=128
    gpu_mem_512=256
    gpu_mem_1024=256
    #overscan_scale=1

    I can provide this. I so not know how to provide what you are asking.


  • administrators

    @jnbui79 http://commonmark.org/help/ (as linked at the top right of the edit box when writing a reply)

    config looks fine - I wanted to check hdmi_safe=1 was disabled as it overrides the other settings.

    Is the HDMI cable long ? If so you may need to increase it further (eg to 9), but I would first try with another cable, in case it's cable related (even though it works with other screens, there could be an issue).



  • I've tried with about 6 other HDMI cables so far. The current one that I am using is 1 meter. Yea I am at a lost myself. I'm going to go pick up a couple other RPi's today and some other HDMI's and adapters and see if I can get this figured out. Maybe time for a new TV? I've been looking for an excuse but it'd be frustrating to let this RPi beat me. I'll keep this updated with my findings.

    Thanks everyone for the assistance


  • administrators

    @jnbui79 You should open a thread on the official Raspberry Pi forums - https://www.raspberrypi.org/ and you may get some more help. They may be able to help you debug it further (some of the devs are there).



  • Wil do, thanks



  • I'm a complete newbie to using RP and having a similar issue with my Samsung TV. In my case it reads "Mode Not Supported" whenever I plug the RP Retropie into it, but it works perfectly on my son's television. I've played with the settings on the samsung, but to no avail. I suppose I must delve into the coding on the pi, which will be a new experience for me as this little project was my first go at it OR I must get a converter box to turn HDMI into RC for use with that TV. I've heard converters make the picture pretty sketchy. Not sure what t
    o to do here!



  • @jnbui79 Any update? I am having this identical issue on my Samsung set. RetroPie works perfectly on every other TV I try it on.....

    Please let me know. Thanks!

    -Craig



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.