Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

N64 on 4.1.6 - still having issues



  • Merry Christmas everyone! This is what dad is doing for Xmas day!

    Still having issues with N64 on Pi 3. I'm running a Raspberry Pi 3 with Retropie 4.1.6 up to date. I've had this issue for some time - the last version I had that worked without this issue was 4.0.2.

    If I use Mupen Rice plugin it works, but I know the Pi 3 works with GlideN64 and also the Glupen plugin as per 4.0.2. BUT - see picture - if I use either GlideN64 or Glupen I get a terrible garbled picture.

    Like I say - Rice works but I know the others work as I use them on 4.0.2. The only changes I make to the configs are to fstab to use the external drive, and also hdmi_group=1 and hdmi_mode=4 to the config.txt (admittedly for reasons I cannot remember). Everything else works well.

    What am I doing wrong? Sorry about the quality of the shot - family don't know how to use phones! Thanks, and merry Christmas again!

    0_1482673021921_PiN64.jpg



  • Never mind folks, looks like I have a bum ROM.

    Thanks again. :)



  • Well...

    Scratch that. It's not the ROM.

    It's only happening with SM64. There's definitely an issue with GlideN64 and Glupen with SM64. Anyone else able to test this to see if they get the same issue? I've tried different ROM's with the same result. Thanks.


  • Global Moderator

    @Ranma

    Have you recently used the update option to build Mupen64Plus "from source"? The most recent source build is known to have graphical issues with 'Super Mario 64' and perhaps others. If this is the case, just use the RetroPie setup menu to remove the emulator and then reinstall using the binary option.



  • @mediamogul

    Thanks for replying. I installed the latest clean image, and then updated the Retropie script and then updated all installed packages. Not sure if this updates from source using this method. I will however try your recommendation of updating from binary.

    Is this likely to be fixed in an upcoming update? I'm more than happy to wait if so, and just stick with 4.0.2 for now. Thanks again.


  • Global Moderator

    @Ranma said in N64 on 4.1.6 - still having issues:

    Is this likely to be fixed in an upcoming update?

    If you are in fact experiencing the issue with the source build, I've heard that the Mupen64Plus GLideN64 team hopes to have a more stable offering before the end of the year. However, this particular issue does not even exist in the current binary version, so you should be fine with it. In most occasions, it's probably just a good idea to stay away from all source builds unless you're prepared to deal with the potential bugs that can accompany them.



  • @mediamogul

    Mario 64 is a regressioniasue with building GLideN64 from Source. Also with glideN64 2.0 just release I am not sure if binary install picks up that version or not? But the issue is GlideN64 not retropie or mupen


  • Global Moderator

    @maz said in N64 on 4.1.6 - still having issues:

    the issue is GlideN64 not retropie or mupen

    Ah, my bad. Good to know and noted above.


  • Global Moderator

    Please update retropie setup and do a source based installation again.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.