Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Random Input PSX Controller GPIO



  • I've noticed a few people have been having issues when using a PSX controller into the GPIO with random button presses seems to be mainly the Select button as it was in my case.

    I came across a thread that was solved (https://retropie.org.uk/forum/topic/6756/solved-ps1-controllers-random-input/5)

    But there were no details as to how to change the clock phase, so I managed to figure it out and thought I'd post what I did hoping it may prove useful to some.

    My Setup:
    H/ware:
    Raspberry Pi 3 Model B w/ 64GB Sandisk class 10 micro SD
    PS1 shell
    Controller ports wired up to the GPIO (if you're reading this you probably already have it connected to the right ports, but if required I will post my connections.

    S/ware
    RetroPie 4.1
    Gamecon GPIO driver

    Before I detail what I did, please note I am no expert at this, and have only owned my Pi just over a week, this is to highlight my steps and wouldn't call this a tutorial. I won't be held responsible for any damage you cause to your Pi.

    1. Connect to Pi through SSH using default log on.

    2. I ran the command: sudo nano /usr/src/gamecon_gpio_rpi-1.2/gamecon_gpio_rpi.c

    3. Search for "clock phase" using ctrl+w and it should look like:

    0_1483470163293_Clock Phase.png

    Looking at the line I believe you can only set these values anywhere between 1 - 5

    1. By default this is set to "3" I changed it to "4" however this did help but did not fully resolve it for me, as this is the case mine is set to "5"

    2. Ctrl+x and then Y to save and then overwrite, then reboot your Pi.

    3. After rebooting reconnect to your Pi and run: jstest /dev/input/js0

    4. Leave the controller plugged in and make sure you don't see any random jumps in controller

    This is what mine looks like after changing the clock phase and leaving at idle for a while, before changing I would see data on the analogue sticks to indicate it had jumped from 0 to 32767.

    0_1483470893717_Jstest.png

    I hope this helps anyone in the same situation, this is my first post, and first time I've ever done anything like this!

    Extra picture of project Pi Station as eye candy!

    0_1483471254733_IMG_20170103_182454.jpg

    PS: I know only one of the controller ports is wired, but I have female jumper cables soldered ready to be connected, just need to make some more Y cables for the GPIO inputs!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.