Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Unable to Save Games (In Game, not Save State)



  • Hi Everyone,
    This post is primarily to give me some direction since it's something I try to fix while I'm at my brother's house, and won't be able to post and wait for the results to troubleshoot. Unfortunately, I'm not entirely sure where to look beyond my initial research.

    I recently finished my first Pi build using a RP3 for my nephew. I did some testing, delivered it to him shortly after Christmas, and figured all was well. For all the testing I did, I never tested if SRM files are working. I'd see them when FTPing new games that some games had .srm files and just assumed they'd save. I didn't want to deliver any games with saves already on them, so I never thought to test.

    The result was a disappointed nephew who finished his first few stars in Mario 64 only to come back to find they were gone. :-(.

    I'm heading over there Sunday to work on resolving this. Initial research shows that this is resolved by exiting the emulator cleanly (Start + Select shortcut) which is what is being used.

    I've also found I can resolve this by going to:
    Opt\Emulators\Retroarch\All\retroarch.cfg

    Then setting the parameter autosave_interval to 1 (most recommend 5, but I think 1 is safer to ensure they can save and exit).

    This is going to be the first thing I try. Unfortunately, I'm concerned that this won't resolve the issue. I can't help but get the feeling that at one point I did test saves and they worked using Super Mario All Stars + World. Since the SRM files are being created when the game is opened, I have the sneaking suspicion that the files aren't being read; or they're being written to, but not read.

    As a bit of a Linux noob, I'm not sure how to verify those permissions are working.

    Also, I think this issue may be related to doing an update. I had a few issues pop up that I had a really difficult time resolving. When 4.1 came out, I ended up wiping the SD Card and writing a new image. One issue I had was scraped metadata was not saving at all. I had to use sselph's scraper in order to get it to save. If I then scraped from thegamesdb, it worked fine, but I did not do that initial scrape using sselph's scraper for each system, it wouldn't stick after a reboot.

    Later on, I had an issue with MAME (unable to get to MAME menu with tab in a different version of MAME) and read a solution of updating packages. I did that and ended up having an issue where I lost my PSX configurations I set up (since some games don't play nice when Analog is selected as controller type, I configured game specific configurations for those games to use standard). So I'm wondering if when I did an update I broke the ability to read, write, or both to SRM files. I'm also wondering if there's a config option, like writing the SRM file on exit that I accidentally disabled at some point, since the emulator is being exited properly AND this setting is disabled by default - it seems like it should be working.

    Like I said earlier, I'm heading over Sunday to see if I can fix it. If setting the autosave_interval to 1 (is there any reason to set it to 5 instead of 1?) doesn't resolve it, any other ideas of what I can look for?

    Thank you in advance for any direction you can give me. I'll report back Sunday.

    EDIT:
    Just spoke to my brother after browsing the tags in this forum (very helpful). Looks like someone is having a similar issue with N64 only and sure enough, the save game issue is only with N64. I'm going to try updating the packages for all the lr-n64 emulators (apparently some fixes were done that improve playability) and seeing deleting the SRM files and letting them create new ones fixes the issue.

    Requested information from !! READ THIS FIRST !! -

    Pi Model or other hardware: Pi 3 (not sure if B)
    Power Supply used: Came with the kit.
    RetroPie Version Used: 4.1 - But I did run an update that may have gone to a newer version.
    Built From: Pre made SD Image on RetroPie website on 4.1
    USB Devices connected: 2 Logitech F310 Controllers
    Controller used: 2 Logitech F310 Controllers
    Error messages received: None
    Emulator: Appears to be all. I think PSX might be saving, but I set up a per-game config for Analog Controllers vs. Standard.
    How to replicate the problem: Unsure if it can be replicated by others.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.