Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Ethernet connection not working



  • I'm very new to raspberry pi and have no clue what I've done or how to fix it. Basically, I was hooking up moonlight to my retropie using a direct connection via ethernet connection to my pc, which worked to begin with, but I messed up something which meant that I rewrote the retropie image onto the microSD so I could start again. However now the direct connection isn't working as I'm typing in "sudo apt-get update" and it's just saying error which it didnt before. I managed to ssh my way into the raspberry pi by editing the "sudo nano /boot/cmdline.txt" to add an ip that putty would connect to. Sorry if this makes no sense, I'm having difficulty grasping some aspects so displaying them in a written text probably won't be good either. Thanks in advance and sorry if a similar problem has been solved, I didn't know what to search for beyond "ethernet connection not working" :)


  • Banned

    @AngryScotsMan type ifconfig in the console / terminal. Do eth0, wlan0 and lo show up fully populated?



  • @COLUMBOSCOAT I typed ifconfig in and it came up with this:

    eth0 Link encap:Ethernet HWaddr b8:27:eb:01:ae:c7
    inet addr:169.254.41.222 Bcast:169.254.255.255 Mask:255.255.0.0
    inet6 addr: fe80::b64:d429:d514:7c15/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:625 errors:0 dropped:0 overruns:0 frame:0
    TX packets:413 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:79985 (78.1 KiB) TX bytes:84328 (82.3 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:720 errors:0 dropped:0 overruns:0 frame:0
    TX packets:720 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1
    RX bytes:58304 (56.9 KiB) TX bytes:58304 (56.9 KiB)

    wlan0 Link encap:Ethernet HWaddr b8:27:eb:54:fb:92
    inet6 addr: fe80::b4a3:e3dd:55c4:fda/64 Scope:Link
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:2 errors:0 dropped:2 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:123 (123.0 B) TX bytes:0 (0.0 B)


  • Banned

    @AngryScotsMan It all looks like it should. I thought maybe the ethernet port was not beong recognised. Have you tried using moonlight via wifi? Just to see if it works.


  • Banned



  • @columboscoat I hadn't used it, I looked somewhere and I swear it said that it wasn't working anymore or that the developer had lost interest and people said moonlight was better so I went with that one. I haven't used wifi, I'm assuming I wouldn't need a dongle to use wifi if it's the model 3-B?


  • Banned

    @AngryScotsMan No dongle. On board wifi.


  • Banned

    @AngryScotsMan Limelight has no support. It still works though. It was really just to see if it would work hardwired via ethernet.



  • @columboscoat I managed to get it working and did all the commands this

    told me to do yet I still haven't got the steam image next to the RetroPie image when I go back to the screen. Any idea on what I need to do know as the video doesn't explain it?


  • Banned

    @AngryScotsMan I launched it from the desktop on my Pi but have a look at this. Steam is near the bottom. https://github.com/Aloshi/EmulationStation/blob/master/SYSTEMS.md



  • @COLUMBOSCOAT Sorry have been very busy the past couple of days, haven't managed to get back on this until now. I think I've been mistaken in how I want it to work. I originally planned to allow games on the game cube, or just more demanding games in general, be able to work with RetroPie and I assumed the only way was through Moonlight but I've realised that I've done it all for steam and can't get the game cube one working and I can only seem to find tutorials with moonlight only being used to get steam games on the Pi. Is it still possible to use moonlight to help with the performance of games like Wind Waker etc on the gamecube or is that not possible or have I just gone the wrong way about this? Sorry I realise this topic/question has now gone away from it's roots and I do apologise for my illiterate skills with this.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.