Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Realtek RTL8152 ethernet USB hub



  • Has anyone gotten their USB ethernet hub which uses the Realtek RTL8152 chip to work in RetroPie? This is the specific chip that sites like Adafruit sells for it's supposedly wide built-in support on Raspberry Pi's - but it doesn't work out of the box with RetroPie on my Zero.

    The only tutorials I've found seem to be how to compile an entire build of a certain flavor of Linux so it includes support for the Realtek. I need to get this to work since my 2.4ghz WiFi seems to be crippled but I could always hard-wire it via ethernet....if I could get this adapter to work...

    Raspberry Pi Zero 1.3, 4.1 image for Pi 0/1 downloaded from RetroPie website installed via ApplePi-Baker onto Samsung EVO card. 2 Amp power supply, etc. etc. Using this exact Micro USB hub with an Ethernet hub.



  • @Dochartaigh
    what does the commands lsusband dmesg say?
    Does ifconfiggives any output?

    Maybe there are more then one revision of this device out and you've received an unsupported.



  • @cyperghost
    Thank you for the things to try! For this testing I actually downloaded a brand new image from the RetroPie site, booted it up for the first time with the ethernet dongle already attached and it seems to work right off the bat! So either A.) The base Raspbian/Jessie (I always forget what RetroPie is built upon) has been updated for support for this chipset in the last couple months or B.) The other times I plugged in the ethernet AFTER it was already booted up (long shot, but only other thing I can think of to explain it as I've tried it several times before and it never worked - albeit probably a month or two ago).

    I'm actually doing all my apt-get updates now and am going to plug in the Bluetooth/Wifi COMBO dongle I also can't get to work...maybe I'll get lucky, but maybe I'll change the topic title to that one if I can't get it to work so I don't have to clutter the forum with another topic.



  • @Dochartaigh That's good.
    For your WIFI/BT dongle, just use the commands I've posted above. Maybe you have luck and find some drivers to compile.



  • Here's the info on my Edimax EW-7611ULB combo bluetooth/wifi dongle I can't get to work:

    lsusb

    Bus 001 Device 003: ID 0bda:8152 Realtek Semiconductor Corp. 
    Bus 001 Device 006: ID 1997:2433  
    Bus 001 Device 005: ID 7392:a611 Edimax Technology Co., Ltd 
    Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    

    dmesg pastbin

    ifconfig. This one is with the bluetooth/wifi combo dongle plugged into the ethernet USB hub - which is the only way I could copy and paste this much text. When I only have the combo dongle and keyboard plugged in the below is definitely different.

    eth0      Link encap:Ethernet  HWaddr 00:e0:4c:36:60:e3  
              inet addr:10.0.0.97  Bcast:10.0.0.255  Mask:255.255.255.0
              inet6 addr: 2601:44:c700:3c07:3544:921b:c24b:df5a/64 Scope:Global
              inet6 addr: fe80::e558:e3a3:b048:8c5d/64 Scope:Link
              inet6 addr: 2601:44:c700:3c07::9d1/128 Scope:Global
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:395 errors:0 dropped:16 overruns:0 frame:0
              TX packets:349 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:41490 (40.5 KiB)  TX bytes:71802 (70.1 KiB)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:4 errors:0 dropped:0 overruns:0 frame:0
              TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1 
              RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)
    

    lsmod (if you need it - somebody else asked for this on another post)

    Module                  Size  Used by
    joydev                  9194  0 
    evdev                  11650  4 
    bnep                   11853  2 
    cfg80211              500089  0 
    btusb                  30722  0 
    btrtl                   4133  1 btusb
    btintel                 8924  1 btusb
    btbcm                   7885  1 btusb
    bluetooth             365780  24 bnep,btbcm,btrtl,btusb,btintel
    rfkill                 21397  3 cfg80211,bluetooth
    cdc_ether               5540  0 
    r8152                  39257  0 
    snd_bcm2835            23131  1 
    snd_pcm                95473  2 snd_bcm2835
    snd_timer              22556  1 snd_pcm
    snd                    68400  4 snd_bcm2835,snd_timer,snd_pcm
    bcm2835_gpiomem         3823  0 
    bcm2835_wdt             4133  0 
    uio_pdrv_genirq         3718  0 
    uio                    10230  1 uio_pdrv_genirq
    uinput                  7735  0 
    fuse                   90472  1 
    ipv6                  367671  34 
    

    ...there's one single post on the entire interned with the Edimax's ID and vendor code...and it's in German...and he also couldn't get it to work. I am trying this post direct from Edimax for the 5th time. Seems like the repository has been down every time I tried it (or the problem with my 2.4ghz wireless internet strikes again) - but seems to be working right now. I'll post back if it's successful.



  • So technically the above worked – I CAN use the Edimax EW-7611ULB combo bluetooth/wifi dongle after following the directions in that link I posted..

    ...but weird stuff is happening:

    1.) The keyboard (Rii mini, 2.4ghz dongle variety) is now ALWAYS player one. I mean ALWAYS. I unplug the keyboard, hit "A" on a hard-wired controller to start a game, and the keyboard is somehow still player 1 and I have to plug the keyboard back in in order to hit "Select + Start" to exit out of a game. Never had that happen before. Furthermore, my bluetooth controllers ALWAYS took priority (i.e. Player 1, then Player 2, etc) over hard-wired controllers no matter what port they were plugged into (don't play mutiplayer that often but I'm pretty sure that's how it always worked).

    2.) WiFi doesn't auto connect. When I go into WiFi setup it even gives me an IP address ending in 140 which totally looks like it's connected if it has an IP address...but it's not really connected (can't SSH or FTP in for example). When I click on connect to a wireless network, re-enter my same password, it then connects, but the IP address changes to end in 12 (which has also never happened since my router I believe always saves the same IP address for a specific dongle...which is how my FTP bookmarks never fail to work).

    3.) Since something is screwy, when I unplug the combo dongle, and (reboot) then plug back in the regular bluetooth dongle (which ALWAYS worked before - no special compiling of drivers needed) -- for the life of me I can't get my 8BitDo wireless controller to connect now (tried 2 different bluetooth controllers).



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.