Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Bluetooth Latency/Lag vs USB for controllers



  • Hello All,
    Just started working on my retropie over the holiday and I love it so far. I am however unable to use my DS4 or DS3 on bluetooth for my RP3 with retropie 4.1 (or latest update per 1/24/17). There just seems to be so much latency that jumps and all actions don't get nearly as responsive as a USB cord. Any advice how I can reduce the latency/lag on bluetooth for either device?

    Pi Model or other hardware: Pi3 B Model
    Power Supply used: CanalKit 2.5 Amp Pi Power Supply
    RetroPie Version Used: 4.1/4.1.11?
    Built From: Premade image available on retropie website.
    USB Devices connected: Sony Official Dualshock 4
    Controller used: (one at a time) Sony Official Dualshock 3 and Sony Official Dualshock 4
    Error messages received: No Error, just controller is much less responsive on bluetooth.
    Guide used: (Mention if you followed a guide) Tried all pages on wiki for
    Emulator: (Name of emulator - if applicable) Affects all emulators (tested SNES, NES, GEN)
    How to replicate the problem:

    I simply connected the devices via bluetooth (not at the same time), and issue occurs, and disappears when connected directly. Bluetooth drivers attempted:

    1. Built in Retropie drivers for Pi3 (for Dualshock 4). Worked but very Laggy and sometimes lost responsiveness
    2. ds4drv, completely killed wifi until uninstalled.
    3. PS3 Controller Driver ("ps3controller"), worked the best (compared to DS4 above) but very laggy.

    Any advice would be much appreciated. Thank you.



  • I have the same Pi model, the PS4 controller and the same issue sometimes. In the config menus the controller is always very slow or does not work at all. In the retrostation frontend it works perfectly fine, also in the emulators, mostly.

    When i have this issue, i just reconnect the controller by holding the PS-Button and Select for around 10 Seconds till it turns off. And then holding those keys for ~2 Seconds till the light turns on again to reconnect.
    When this won't help i recommend to remove the bluetooth device in the config completly and then add it again. I had to do this once.
    But as said, it works just fine most of the time i haven't done anything special.



  • Thanks for the advice, unfortunately, the issue remains after resetting the controller. Are you using the built in bluetooth (while connected to wifi) or are you using a dedicated BT dongle?



  • I'm using the build in BT.
    Maybe the BT "Module" on your pi is faulty. At least it doesn't sound normal that both controllers don't work correctly via BT.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.