Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Correct location for PSX Rearmed Bios? Always selects HLE



  • Hello,

    Where is the correct place to out the bios file to get it recognised by the ps1 emulator?

    I currently have it in my /BIOS folder it is SCPH1001.BIN (all caps) and has 924e392ed05558ffdb115408c263dccf with permissions set to 644

    i have read loads of threads on here and other sites i think its in the right place but just wont load or allow me to change it in the options.

    Any ideas what im doing wrong?



  • additionially, i have now tried copying to /opt/retropie/emulators/pcsx-rearmed/bios/

    and also into /roms/psx

    still the same, wont find it.



  • @a7mag3ddon just in case you have an ownership issue set the one in the bios folder to 0777 permissions and see what happens.



  • It's ok i have figured it out, the WIKI is wrong.

    the only way i can avoid the HLE warning and select my own bios files in the options is to copy them to /home/pi/bios

    which seems totally against all the info on the web which says to put in the normal BIOS folder with all the other systems bios files.

    I have removed ALL instances of bios files and got the emulator to go back to the HLE then re-put them into /pi/bios and then the options come back.

    I have opened an issue on the wiki for it because in my case the info on the wiki is wrong.



  • @a7mag3ddon said in Correct location for PSX Rearmed Bios? Always selects HLE:

    It's ok i have figured it out, the WIKI is wrong.

    Why is the WIKI wrong? It clearly says where to put https://github.com/retropie/retropie-setup/wiki/playstation-1#bios



  • You have made my point perfectly....

    WIKI SAYS
    Place SCPH1001.BIN in

    /home/pi/RetroPie/BIOS

    it DOESNT work in that folder...

    read how i fixed it.


  • administrators

    @a7mag3ddon I will look into this - but is there any reason you are not running the libretro core (which is easier to use than the standalone) ?


  • administrators

    Standalone pcsx-rearmed works fine with the BIOS in the `~/RetroPie/BIOS folder as mentioned in the wiki - I have just confirmed it on a fresh install.

    Please post the output of this from a terminal

    ls -la /opt/retropie/emulators/pcsx-rearmed/bios
    

    that should be a symlink to the bios file



  • I couldn't get the game to work on the LR version and it wouldn't work properly had garbled video and was totally unplayable, so then i switched to the other emulator and the game fired up without issues, but when i had chosen all my game settings and started the game it crashed back to pi. ... then i read its better to use the proper bios... hence me then trying to get that working.. b



  • here it is..

    scph1001.bin -> /home/pi/RetroPie/BIOS/ scph1001.bin


  • administrators

    Small correction - the bios file should be lowercase for this emulator - I think what has happened here is the lr-pcsx-rearmed emulator can handle the bios named uppercase or lowercase, but we symlink the lowercase version for this emulator. I will add an additional symlink.



  • It is lower case



  • Lastnight i tried caps, caps and lower ext, all caps, all lower.



  • Thing is though, now my roms are in the /pi/bios folder, within the emulator i can choose any of them and i have 5 in there.

    Do you only need the 1001 for all systems even if game is pal/usa/jap psx ?


  • administrators

    @a7mag3ddon ok. I will check / confirm and provide a fix if needed. It's possible something has changed over the recently development (not many people use this emulator) - most use the libretro core.



  • yeah i appreciate that it might not be used, but the wiki should reflect the correct set up instructions for it :-)

    its the first place i and other will look for an answer, i always post here as a last resort and everyone i spoke to on FB pi pages just quoted the wiki at me !


  • administrators

    @a7mag3ddon People may have thought you were talking about the libretro core. the standalone emulator was added more recently (not by me originally), and may have problems - I can confirm there is some path issue here (I misread something in my earlier test).

    We do this in our free time and the wiki is user editable. Sometimes things are not covered.



  • Possible on here they may have taken that as being the LR core but on the facebook pages i posted a massive thread on i did say i specifically that the LR core for this particular game didn't display properly and that's why i was using this one, i even posted photos of the emulator, but i haven't seen the LR version so not sure if its the same look or not i will have to check :-)

    In the end the game still crashed when i pressed start on the menu any ways but i just wanted to let people know with my findings was all.

    I don't like editing wikis in case i am wrong and look silly.

    But its all good, i dont feel like i wasted 2 hours trying to work it all out and to be honest i found that /pi/bios folder by accident this morning.


  • administrators

    the problem was that the bios folder wasn't found when launching unless you were in the correct folder on launch - I guess this was missed when the module was created. This has been corrected now - I also made it use the uppercase bios name by default to match wiki/lr-pcsx-rearmed instructions.

    Please update retropie-setup and re-install the emulator.



  • but the bios it will use will be scph1001.bin correct? is that ok for all region games?


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.