Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • RaspberryPi 3 Model B
    RetroPi 4.1.14
    Build from: SD Image
    USB devices connected: Dell Multimedia Keyboard -KB115
    Controllers Connected: PS3 from experimental drivers
    Error message: no errors just no response

    All of my emulators work perfectly fine with my keyboard until I have to go into command line to shutdown. Nothing responds.
    I tried Ctrl+Alt+Del on it aswell as escape. No keys seem to respond. However, when I press Shift+3 I get "£" and when I do Shift+~ I get "¬". These are the only characters that appear. I am worried because I don't like hard resetting my Pi. I have tried this with two different keyboards, both wired USB. I have had a PS3 controller connected at the time but even pressing buttons on the PS3 controller nothing would work. This has also happen without the PS3 controller connected. I'm fairly new to RetroPi, but i am familiar with command line and simple Linux concepts. I hope this is enough information to get anything. Thanks!


  • @michaellyne77 not sure if it's your case, but I faced this kind of issue and typed reset and then <ENTER> to reinitialize the terminal and it solved.

    Actually the keyboard was working, but the keys I was pressing were not appearing on the screen.

    Try it and see.


  • @michaellyne77
    This happens to me everytime I use a non-libretro emulator like Mupen64. Exit to command line and no characters will show up, except I know the keyboard is working because the underscore flashes in sync with any button I press. Just no letters.

    I'm going to try the above poster's suggestion when I get home from my weekend vacation.


  • I have the same issue. As soon as I load a N64 game, my keyboard does not respond anymore when I quit retropie to the command line. I did not find any workarounds to reset the keyboard. Please help me to fix this annoying problem!


  • @8daysaweek did you tried what I suggested above?
    Type reset (you won't see what you're typing on the screen) and then press <enter>. This commands resets the terminal and can maybe solve your issue.


  • Yes I tried, the keyboard does not respond at all after I quit. When I am still in Retropie, keyboard and PS3 controller work like a charm. What would be the script name used by Retropie upon Exit? I could try to force a reset there. Any ideas are quite welcome. Thanks.


  • Could this be related to the issue with EmulationStation trying to save metadata for a relatively large collection of ROMs on shutdown/reboot?
    https://github.com/retropie/retropie-setup/wiki/FAQ#why-does-shut-down-and-reboot-take-ages


  • I do not think it is related, I have a small amount of roms for only 3 emulators. Let me emphasize that I loose keyboard control only when I load a N64 rom. It does not happen with any NES/SNES roms. Thanks for any helps!


  • @8daysaweek

    Let me emphasize that I loose keyboard control only when I load a N64 rom.

    Which N64 emulator are you using?


  • mupen64plus. I could try another emulator if you kindly tell me how.


  • @8daysaweek you arent unplugging a controller after exiting mupen64 are you?


  • No, none of us are doing anything out of the ordinary.

    If you start a non-libretro N64 emulator, the keyboard ceases to function in the command line. That's it. Most people aren't exiting to command line after playing N64, so it's not something widely known.


  • I too am having this problem, but mine is even worse as any non libretto n64 emulator does not work at all.


  • @mvgilpatrick your chances to get help increases if you open a new thread specific to your issue. Be sure to give as much info about your setup as possible (good advice on how to get help here: https://retropie.org.uk/forum/topic/3/read-this-first ).

    Showing ways to reproduce your issue always helps.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.