Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Arcade Emulator Selection Per ROM In Launch Config Only Works Once, Gets Stuck



  • Had essentially the same issue as, and followed the instructions in, this thread:

    Re: Can't select emulator for ROM

    however, the advice given, changing the permissions, didn't work for me. To describe the issue, when I open the launch configuration menu, any time I try Select Emulator for ROM, it only works once and then becomes stuck. If I try to choose Remove Emulator Choice for ROM it doesn't work. This is the same case for all of my arcade ROMs; once an emulator choice has been made, it cannot be unmade. This happened earlier today seemingly out of the blue and I have been trying to get to the bottom of it with no luck. Earlier, I said I had "essentially" the same issue as the person in the aforementioned thread. The reason I say "essentially" is that I didn't get the same error message as him, sed: couldn’t open temporary file /opt/retropie/configs/all/<temp name>: Permission denied. I'm getting no error at all as far as I can tell, unless it is appearing far too quickly for me to see. If I select either option, nothing really happens differently; that is to say, each option in the config menu progresses normally and there is no error message but neither option actually does anything after an emulator has been selected for the ROM once. If I try Select Emulator for ROM, it goes to the next screen, the emulator selection screen, like normal, but when I select an emulator, after it reverts to the launch config menu, the emulator selection is still the same as the first time. When I select Remove Emulator Choice for ROM, nothing happens, the emulator choice remains what it was rather than changing to the empty set of parentheses that indicate the emulator choice has been cleared (). Since my problem doesn't seem to be related to permissions of the configs (at least as far as I can tell without seeing that same error message and without knowing of a log that collects info specifically about the launch config menu and not the launch itself), I'm not sure what to do. Also, for good measure, I tried the same thing with another ROM, this time an SNES ROM, and the same thing happened; the choice got stuck. Any advice? Let me know if I need to provide anything to get to the bottom of it. Thanks!

    Raspberry PI model is 3
    Version is 4.1.14
    Build is from the SD card image, updated it in hope that it may solve the issue (it didn't).



  • Fixed it.

    After some digging, I looked at /opt/retropie/configs/all/emulators.cfg and noticed this:

    mame-mame4all_jojoba = "lr-imame4all"
    mame-libretro_xmcotau = "lr-mame2003"
    mame-libretro_strider2 = "lr-imame4all"
    mame-libretro_1942b = "lr-mame2010"
    mame-libretro_captcomm = "lr-mame2010"
    mame-libretro_spaceinv = "lr-imame4all"
    mame-libretro_galmidw = "lr-mame2010"
    mame-libretro_centiped = "lr-mame2010"
    mame-libretro_centipd2 = "lr-mame2010"
    mame-advmame_centipd2 = "advmame-3.2"
    mame-libretro_galaga = "lr-mame2010"
    arcade_jojoban = "lr-fbalpha"
    arcade_dkong = "lr-mame2003"
    arcade_frogger = "lr-mame2003"
    arcade_galaga = "advmame-3.2"
    arcade_spyhunt = "lr-imame4all"
    arcade_tapper = "lr-imame4all"
    arcade_choplift = "lr-mame2010"
    arcade_1942 = "lr-fbalpha"
    arcade_1943 = "lr-fbalpha"
    arcade_buckyua = "mame4all"
    arcade_goldnaxe = "lr-mame2010"
    arcade_raiden = "lr-fbalpha"
    arcade_raiden2 = "lr-fbalpha"
    arcade_ktmnt = "lr-mame2010"
    arcade_tmnt_104 = "lr-imame4all"
    arcade_rampage = "lr-imame4all"
    arcade_sf2ce = "lr-fbalpha"
    arcade_sf2hf = "lr-fbalpha"
    arcade_sfa = "lr-mame2010"
    arcade_sfa2 = "lr-mame2010"
    arcade_sfa3 = "lr-mame2010"
    arcade_mk3 = "lr-mame2010"
    arcade_mk4 = "lr-mame2010"
    arcade_sfiii = "advmame-3.2"
    arcade_sfiii3 = "lr-fbalpha"
    arcade_StreetFighterIII3rdStrike-FightfortheFutureUSCP3000U0G-CAP-33S0A0NA = "lr-fbalpha"
    arcade_sfiii3n = "lr-fbalpha"
    arcade_ddsom = "lr-mame2010"
    arcade_outrun1 = "lr-fbalpha"
    \00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00
    arcade_outrun = "lr-fbalpha"
    arcade_aburner2 = "lr-fbalpha"
    arcade_aburner = "lr-fbalpha"
    arcade_altbeast = "lr-fbalpha"
    arcade_ga2 = "lr-fbalpha"
    arcade_ga21 = "advmame-0.94.0"
    snes_3NinjasKickBackU = "lr-snes9x2010"
    

    I noticed there was a line of \00's. Deleting that line worked!



  • @devorange it's just remove the 00000 for solve it?
    because i try to write that:
    /opt/retropie/configs/all/emulators.cfg
    but that's the answer...
    -bash: /opt/retropie/configs/all/emulators.cfg: Permission denied
    If you can help me, your post is the only one I found with the same problem than me.
    Thank you very much



  • @llunstiklimber You're not doing it right. Run from terminal/command prompt:

    nano /opt/retropie/configs/all/emulators.cfg
    

    and you'll be able to see and edit the file.



  • @mitu yeah! thanks.
    It's another kind of menu but i think it's the same anyway. What i must to do now? I just must erase the options recorded?



  • @llunstiklimber Look to see if you have the same problem as the original poster - the string of \00s - and delete the offending line(s).
    If not, then you might have a different problem.



  • @mitu no, just that:
    I remove the last line, and i try the game, and yeah it works.0_1528920487349_pantallazo.jpg
    But if this help, when i try to remove the emulator from this menu:

    0_1528922297350_pantallazo2.jpg
    appears this message :
    sed: couldn't open temporary file/option/retropie/configs/all/emulators/sed(uvsdse*)Permission denied
    *theses characters after "sed" changing every time I press Remove emulator choice for ROM



  • @llunstiklimber Check the permissions on the folder for the .cfg file, you might have accidentally changed them. You can fix them with the following commands:

    sudo chown -R pi:pi  /opt/retropie/configs/all
    sudo chmod 0755 /opt/retropie/configs/all
    


  • use sudo nano /opt/retropie/configs/all/emulators.cfg, otherwise it won't allow you to save the file

    That way you shouldn't have to change permissions either



  • @mitu I think no. But i dont really know if something change or not... or if i did it wrong when I writed that lines (no error message, just go down to the next line) but still having the same problem with the blue menu "in game"
    Just another stupid question for my part, .how I can restart the rasp, or the system in the command menu (this one we are working) because I don't know if need to restart or save the changes.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.